]> git.pld-linux.org Git - packages/perl-Package-Generator.git/blob - perl-Package-Generator.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Package-Generator.git] / perl-Package-Generator.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Package
6 %define pnam    Generator
7 Summary:        Package::Generator - generate new packages quickly and easily
8 Summary(pl.UTF-8):      Package::Generator - szybkie i łatwe generowanie nowych pakietów
9 Name:           perl-Package-Generator
10 Version:        1.106
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Package/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  92ed633a2d18bbe22d8feda32f761de3
17 URL:            http://search.cpan.org/dist/Package-Generator/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Simple >= 0.96
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module lets you quickly and easily construct new packages. It
29 gives them unused names and sets up their package data, if provided.
30
31 %description -l pl.UTF-8
32 Ten moduł pozwala szybko i łatwo konstruować nowe pakiety. Nadaje im
33 unikalne nazwy i w razie potrzeby konfiguruje dane.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/Package/Generator.pm
58 %{perl_vendorlib}/Package/Reaper.pm
59 %{_mandir}/man3/Package::Generator.3pm*
60 %{_mandir}/man3/Package::Reaper.3pm*
This page took 0.135573 seconds and 4 git commands to generate.