]> git.pld-linux.org Git - packages/perl-PPIx-Regexp.git/blob - perl-PPIx-Regexp.spec
- updated shebang fix
[packages/perl-PPIx-Regexp.git] / perl-PPIx-Regexp.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    PPIx
6 %define         pnam    Regexp
7 Summary:        PPIx::Regexp - represent a regular expression of some sort
8 Summary(pl.UTF-8):      PPIx::Regexp - reprezentacja pewnego rodzaju wyrażenia regularnego
9 Name:           perl-PPIx-Regexp
10 Version:        0.050
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/W/WY/WYANT/PPIx-Regexp-%{version}.tar.gz
16 # Source0-md5:  512573bd4c597e96ce07ff11d50a7df6
17 URL:            http://search.cpan.org/dist/PPIx-Regexp/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-List-MoreUtils
23 BuildRequires:  perl-PPI >= 1.117
24 BuildRequires:  perl-Task-Weaken
25 BuildRequires:  perl-Test-Simple >= 0.40
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This package parses regular expressions as they appear in Perl
32 scripts, generating a structure similar to the structure generated by
33 PPI when it parses a Perl script, and navigable in much the same way.
34
35 %description -l pl.UTF-8
36 Ten pakiet analizuje wyrażenia regularne w takiej postaci, w jakiej
37 występują w skryptach perlowych, tworząc strukturę podobną do
38 struktury generowanej przez PPI przy analizie skryptu perlowego i
39 dającą się przeglądać w bardzo podobny sposób.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Build.PL \
46         destdir=$RPM_BUILD_ROOT \
47         installdirs=vendor
48 ./Build
49
50 %{?with_tests:./Build test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 ./Build install
56
57 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58 cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' \
61         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/preslurp
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %{perl_vendorlib}/PPIx/Regexp.pm
70 %{perl_vendorlib}/PPIx/Regexp
71 %{_mandir}/man3/PPIx::Regexp*.3pm*
72 %{_examplesdir}/%{name}-%{version}
This page took 0.091815 seconds and 4 git commands to generate.