]> git.pld-linux.org Git - packages/perl-POSIX-strftime-Compiler.git/blob - perl-POSIX-strftime-Compiler.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-POSIX-strftime-Compiler.git] / perl-POSIX-strftime-Compiler.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    POSIX
6 %define         pnam    strftime-Compiler
7 Summary:        POSIX::strftime::Compiler - GNU C library compatible strftime for loggers and servers
8 Name:           perl-POSIX-strftime-Compiler
9 Version:        0.42
10 Release:        2
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/POSIX/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  c0a5f76b1b0ce9cdb90d627b017e6cf5
16 URL:            https://metacpan.org/release/POSIX-strftime-Compiler/
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 POSIX::strftime::Compiler provides GNU C library compatible strftime(3). But this module will not affected
27 by the system locale.  This feature is useful when you want to write loggers, servers and portable applications.
28
29 For generate same result strings on any locale, POSIX::strftime::Compiler wraps POSIX::strftime and 
30 converts some format characters to perl code
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Build.PL \
37         destdir=$RPM_BUILD_ROOT \
38         installdirs=vendor
39 ./Build
40
41 %{?with_tests:./Build test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 ./Build install
47
48 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes
57 %{perl_vendorlib}/POSIX/strftime
58 %{_mandir}/man3/POSIX::strftime::Compiler.3*
59 %{_examplesdir}/%{name}-%{version}
This page took 0.076451 seconds and 3 git commands to generate.