3 %bcond_without tests # do not perform "make test"
6 %define pnam Sugar-Args
7 Summary: POE::Sugar::Args - get "pretty", OO representation of args
8 Summary(pl.UTF-8): POE::Sugar::Args - "ładna", obiektowo zorientowana reprezentacja argumentów
9 Name: perl-POE-Sugar-Args
13 License: GPL v1+ or Artistic
14 Group: Development/Languages/Perl
15 Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5: 99b1a0c0abb3a25353603bb79be7d005
17 URL: http://search.cpan.org/dist/POE-Sugar-Args/
18 BuildRequires: perl-devel >= 1:5.8.0
19 BuildRequires: rpm-perlprov >= 4.1-13
21 BuildRequires: perl-Devel-Caller-Perl
22 BuildRequires: perl-Exporter-Lite
23 BuildRequires: perl-POE
26 BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29 This module give an OO representation to arguments POE passes to event
30 states. I will not lie to you. This adds heavy, bulky code underneath.
31 On the other hand, it makes arguments for POE events much more
32 palatable. Of course, this is a Sugar module, meaning, it will rot
33 your program in odd (you'll be hooked) and unexpected ways
34 (performace), but you took the candy so you can suffer the
35 consequences. Good luck.
37 %description -l pl.UTF-8
38 Ten moduł nadaje obiektowo zorientowaną reprezentację argumentom,
39 które POE przekazuje do stanów zdarzeń. Autor nie zamierza kłamać -
40 ten moduł dodaje ciężki, masywny kod. Z drugiej strony, czyni
41 argumenty zdarzeń POE bardziej smacznymi. Oczywiście jest to moduł
42 Sugar (cukier), co oznacza, że program zgnije w dziwny i nieoczekiwany
43 sposób (wydajność), ale używający tego modułu bierze cukierek i może
44 znosić konsekwencje. Powodzenia.
47 %setup -q -n %{pdir}-%{pnam}-%{version}
51 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"POE::Sugar::Args",PL_FILES=>{})' \
55 %{?with_tests:%{__make} test}
58 rm -rf $RPM_BUILD_ROOT
61 DESTDIR=$RPM_BUILD_ROOT
64 rm -rf $RPM_BUILD_ROOT
67 %defattr(644,root,root,755)
68 %{perl_vendorlib}/%{pdir}/*