]> git.pld-linux.org Git - packages/perl-POE-Quickie.git/blob - perl-POE-Quickie.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-POE-Quickie.git] / perl-POE-Quickie.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    POE
6 %define         pnam    Quickie
7 Summary:        POE::Quickie - A lazy way to wrap blocking code and programs
8 #Summary(pl.UTF-8):
9 Name:           perl-POE-Quickie
10 Version:        0.18
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/POE/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a510c905e4bc84fb945ab0a2d85dfd16
17 URL:            http://search.cpan.org/dist/POE-Quickie/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Capture::Tiny) >= 0.07
22 BuildRequires:  perl-POE >= 1.291
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 If you need nonblocking access to an external program, or want to
29 execute some blocking code in a separate process, but you don't want
30 to write a wrapper module or some POE::Wheel::Run boilerplate code,
31 then POE::Quickie can help. You just specify what you're interested in
32 (stdout, stderr, and/or exit code), and POE::Quickie will handle the
33 rest in a sensible way.
34
35 It has some convenience features, such as killing processes after a
36 timeout, and storing process-specific context information which will
37 be delivered with every event.
38
39 There is also an even lazier API which suspends the execution of your
40 event handler and gives control back to POE while your task is
41 running, the same way LWP::UserAgent::POE does. This is provided by
42 the quickie_* functions which are exported by default.
43
44 # %description -l pl.UTF-8 # TODO
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} pure_install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %{perl_vendorlib}/POE/*.pm
69 %{_mandir}/man3/*
This page took 0.096459 seconds and 4 git commands to generate.