]> git.pld-linux.org Git - packages/perl-POE-Component-Schedule.git/blob - perl-POE-Component-Schedule.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-POE-Component-Schedule.git] / perl-POE-Component-Schedule.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    POE
6 %define pnam    Component-Schedule
7 Summary:        POE::Component::Schedule - Schedule POE events using DateTime::Set iterators
8 Summary(pl.UTF-8):      POE::Component::Schedule - Planuje zdarzenia POE przy użyciu iteratorów DateTime::Set
9 Name:           perl-POE-Component-Schedule
10 Version:        0.03
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/D/DO/DOLMEN/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7f3b1b2b368d588243c1c74685de3cd4
17 URL:            http://search.cpan.org/dist/POE-Component-Schedule/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-DateTime
22 BuildRequires:  perl-DateTime-Set >= 0.25
23 BuildRequires:  perl-DateTime-TimeZone
24 BuildRequires:  perl-POE >= 1.000
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This component encapsulates a session that sends events to client sessions
31 on a schedule as defined by a DateTime::Set iterator.
32
33 %description -l pl.UTF-8
34 Moduł ten planuje zdarzenia POE przy użyciu iteratorów DateTime::Set.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Build.PL \
41         destdir=$RPM_BUILD_ROOT \
42         installdirs=vendor
43 ./Build
44
45 %{?with_tests:./Build test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 ./Build install
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/POE/Component/*.pm
59 %{_mandir}/man3/*
This page took 0.077564 seconds and 4 git commands to generate.