]> git.pld-linux.org Git - packages/perl-POE-Component-SSLify.git/blob - perl-POE-Component-SSLify.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-POE-Component-SSLify.git] / perl-POE-Component-SSLify.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5 #
6 %define         pdir    POE
7 %define         pnam    Component-SSLify
8 Summary:        POE::Component::SSLify - make using SSL in the world of POE easy
9 Summary(pl.UTF-8):      POE::Component::SSLify - łatwe używanie SSL-a w świecie POE
10 Name:           perl-POE-Component-SSLify
11 Version:        0.15
12 Release:        1
13 # "same as perl" according to readme
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/POE/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  d4bf013f253d36e17cf0233964654edb
18 URL:            http://search.cpan.org/dist/POE-Component-SSLify/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with autodeps} || %{with tests}
22 BuildRequires:  perl-IO-stringy
23 BuildRequires:  perl-Net-SSLeay >= 1.30
24 %endif
25 Requires:       perl-Net-SSLeay >= 1.30
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module makes Net::SSLeay's SSL sockets behave with POE.
31
32 %description -l pl.UTF-8
33 Ten moduł pozwala na współpracę gniazd SSL z Net::SSLeay z POE.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README
58 %{perl_vendorlib}/POE/Component/SSLify.pm
59 %dir %{perl_vendorlib}/POE/Component/SSLify
60 %{perl_vendorlib}/POE/Component/SSLify/*.pm
61 %{_mandir}/man3/*
This page took 0.090871 seconds and 4 git commands to generate.