]> git.pld-linux.org Git - packages/perl-POE-Component-Pluggable.git/blob - perl-POE-Component-Pluggable.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-POE-Component-Pluggable.git] / perl-POE-Component-Pluggable.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    POE
6 %define pnam    Component-Pluggable
7 Summary:        POE::Component::Pluggable - A base class for creating plugin-enabled POE Components
8 Summary(pl.UTF-8):      POE::Component::Pluggable - klasa bazowa do tworzenia komponentów POE jako wtyczek
9 Name:           perl-POE-Component-Pluggable
10 Version:        1.26
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/B/BI/BINGOS/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  989a64c6c2939a19ee5844c9d9e87047
17 URL:            http://search.cpan.org/dist/POE-Component-Pluggable/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.42
22 BuildRequires:  perl-POE >= 1.004
23 BuildRequires:  perl-Task-Weaken
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 POE::Component::Pluggable is a base class for creating plugin enabled
30 POE Components. It is a generic port of POE::Component::IRC's plugin
31 system.
32
33 If your component dispatches events to registered POE sessions, then
34 POE::Component::Pluggable may be a good fit for you.
35
36 %description -l pl.UTF-8
37 POE::Component::Pluggable jest klasą bazową dla tworzenia komponentów
38 POE jako wtyczek. Jest to ogólny port systemu wtyczek
39 POE::Component::IRC.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} pure_install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorlib}/POE/Component/*.pm
67 %{perl_vendorlib}/POE/Component/Pluggable
68 %{_mandir}/man3/*
69 %{_examplesdir}/%{name}-%{version}
This page took 0.102482 seconds and 4 git commands to generate.