]> git.pld-linux.org Git - packages/perl-POE-Component-IKC.git/blob - perl-POE-Component-IKC.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-POE-Component-IKC.git] / perl-POE-Component-IKC.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5 #
6 %define         pdir    POE
7 %define         pnam    Component-IKC
8 Summary:        POE::Component::IKC - POE Inter-Kernel Communication
9 Summary(pl.UTF-8):      POE::Component::IKC - komunikacja wewnątrz jądra POE
10 Name:           perl-POE-Component-IKC
11 Version:        0.2302
12 Release:        1
13 # "same as perl"
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  25a1bd34dacae9a8937dcb1078b1b99d
18 URL:            http://search.cpan.org/dist/POE-Component-IKC/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with autodeps} || %{with tests}
22 BuildRequires:  perl-POE >= 2:1.311
23 BuildRequires:  perl-POE-API-Peek >= 1
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This a first draft if Inter-Kernel Communication for POE. It is
30 intended as a point of reference for discusion of issues involved.
31
32 %description -l pl.UTF-8
33 To jest pierwszy szkic komunikacji wewnątrz jądra dla POE. Ma być
34 punktem odniesienia do dyskutowania napotkanych problemów.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} pure_install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README TODO FUTUR ikc-architecture.txt
59 %{perl_vendorlib}/POE/Component/IKC.pm
60 %dir %{perl_vendorlib}/POE/Component/IKC
61 %{perl_vendorlib}/POE/Component/IKC/*.pm
62 %{_mandir}/man3/*
This page took 0.112014 seconds and 4 git commands to generate.