]> git.pld-linux.org Git - packages/perl-POE-Component-Client-Ident.git/blob - perl-POE-Component-Client-Ident.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-POE-Component-Client-Ident.git] / perl-POE-Component-Client-Ident.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    POE
6 %define pnam    Component-Client-Ident
7 Summary:        POE::Filter::Ident - A POE-based parser for the Ident protocol
8 Summary(pl.UTF-8):      POE::Filter::Ident - oparty na POE analizator protokołu Ident
9 Name:           perl-POE-Component-Client-Ident
10 Version:        1.16
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/POE/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  cfe5b1e3658df5455ed43526325b239a
17 URL:            http://search.cpan.org/dist/POE-Component-Client-Ident/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-POE >= 0.0607
22 BuildRequires:  perl-Test-POE-Server-TCP
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 POE::Filter::Ident takes lines of raw Ident input and turns them into
29 weird little data structures, suitable for feeding to
30 POE::Component::Client::Ident::Agent. They look like this: 
31
32 { name => 'event name', args => [ some info about the event ] }
33
34 %description -l pl.UTF-8
35 POE::Filter::Ident przyjmuje linie surowego wejścia od Identa i
36 zamienia je na dziwne małe struktury danych, nadające się do
37 przekazywania do modułu POE::Component::Client::Ident::Agent.
38 Wyglądają tak:
39
40 { name => 'nazwa zdarzenia', args => [ informacja o zdarzeniu ] }
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorlib}/POE/Component/Client/*.pm
65 %{perl_vendorlib}/POE/Component/Client/Ident
66 %{perl_vendorlib}/POE/Filter/Ident.pm
67 %{_mandir}/man3/*
This page took 0.080941 seconds and 4 git commands to generate.