]> git.pld-linux.org Git - packages/perl-POD2-Base.git/blob - perl-POD2-Base.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-POD2-Base.git] / perl-POD2-Base.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    POD2
6 %define         pnam    Base
7 Summary:        Base module for translations of Perl documentation
8 Summary(pl.UTF-8):      Bazowy moduł do tłumaczeń dokumentacji Perla
9 Name:           perl-POD2-Base
10 Version:        0.044_1
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/POD2/FERREIRA/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8dd5125ba5026427cafdddaa7f5946a9
17 URL:            http://search.cpan.org/dist/POD2-Base/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Simple
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module is an abstraction of the code in POD2::IT and POD2::FR.
28 These modules belong to the Italian and the French translation
29 projects of core Perl pods.
30
31 %description -l pl.UTF-8
32 Ten moduł to abstrakcja dla kodu w pakietach POD2::IT oraz POD2::FR.
33 Moduły te należą do projektów tłumaczenia podstawowych plików pod z
34 Perla na język włoski i francuski.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/POD2/Base.pod
53 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/POD2/PT/POD2/Base.pod
54 rmdir $RPM_BUILD_ROOT%{perl_vendorlib}/POD2/PT/POD2
55 rmdir $RPM_BUILD_ROOT%{perl_vendorlib}/POD2/PT
56
57 install -d $RPM_BUILD_ROOT%{_mandir}/pt/man3
58 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man3/POD2::PT::POD2::Base.3pm $RPM_BUILD_ROOT%{_mandir}/pt/man3/POD2::Base.3pm
59
60 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes
69 %dir %{perl_vendorlib}/POD2
70 %{perl_vendorlib}/POD2/Base.pm
71 %{_mandir}/man3/POD2::Base.3pm*
72 %lang(pt) %{_mandir}/pt/man3/POD2::Base.3pm*
73 %{_examplesdir}/%{name}-%{version}
This page took 0.162732 seconds and 4 git commands to generate.