]> git.pld-linux.org Git - packages/perl-PAR.git/blob - perl-PAR.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-PAR.git] / perl-PAR.spec
1 # ToDo:
2 # - include /usr/bin/part and /usr/bin/tkpp or not?
3 #
4 # Conditional build:
5 %bcond_without  tests   # do not perform "make test"
6 #
7 %define         pdir    PAR
8 Summary:        Perl Archive Toolkit
9 Summary(pl.UTF-8):      Zestaw narzędzi perlowych do archiwizacji
10 Name:           perl-PAR
11 Version:        1.015
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/PAR/%{pdir}-%{version}.tar.gz
17 # Source0-md5:  7a071dd811176fafe74ff054cb8962ce
18 URL:            http://par.perl.org/
19 BuildRequires:  perl-Archive-Zip >= 1.00
20 %if %{with tests}
21 BuildRequires:  perl(Compress::Zlib) >= 1.30
22 BuildRequires:  perl-Digest-SHA1
23 BuildRequires:  perl-Module-ScanDeps >= 0.45
24 BuildRequires:  perl-Module-Signature >= 0.35
25 %endif
26 BuildRequires:  perl-PAR-Dist >= 0.06
27 BuildRequires:  perl-devel >= 1:5.8.0
28 BuildRequires:  rpm-perlprov >= 4.1-13
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Perl Archive Toolkit:
33 - Do what JAR (Java Archive) does for Perl
34 - Platform-independent, compressed file format (zip)
35 - Aggregates modules, scripts and other files into one file
36 - Easy to generate, update and extract
37 Benefits of using PAR:
38 - Reduced download and deployment time
39 - Saves disk space by compression and selective packaging
40 - Version consistency: solves forward-compatibility problems
41 - Community support: par@perl.org
42 You can also turn a PAR file into a self-contained script
43 - Bundles all necessary 3rd-party modules with it
44 - Requires only core Perl to run on the target machine
45 - If you use pp to compile the script...
46 - ...you get an executable not even needing core Perl
47
48 %description -l pl.UTF-8
49 Perl Archive Toolkit:
50 - robi to samo, co JAR (archiwizator Javy), ale dla Perla
51 - używa niezależnego od platformy, formatu pliku skompresowanego (zip)
52 - integruje w jeden plik moduły, skrypty i inne pliki
53 - pliki PAR są łatwe do wygenerowania, aktualizacji i rozpakowania
54 Korzyści płynące ze stosowania PAR:
55 - skrócenie czasu pobierania i wdrożenia programu
56 - oszczędność miejsca na dysku wynikająca z kompresji i wybiórczego
57   pakietowania
58 - spójność wersji: rozwiązuje problemy zgodności w przód
59 - wsparcie zespołu: par@perl.org
60 Można również przekształcić plik PAR w skrypt zawierający pakiet
61 - łączy w sobie wszystkie niezbędne obce moduły
62 - wymaga do uruchomienia na maszynie docelowej jedynie podstawowego
63   Perla
64 - przy wykorzystaniu pp do kompilacji skryptu...
65 - ...dostaje się program uruchamialny nie wymagający nawet
66   podstawowego Perla
67
68 %prep
69 %setup -q -n %{pdir}-%{version}
70
71 %build
72 %{__perl} Makefile.PL \
73         INSTALLDIRS=vendor \
74         --skipdeps      # make ExtUtils::Autoinstall non-interactive
75
76 %{__make} \
77         CC="%{__cc}" \
78         OPTIMIZE="%{rpmcflags}"
79
80 %{?with_tests:%{__make} test}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc README Changes AUTHORS
94 %{perl_vendorlib}/PAR.pm
95 %{perl_vendorlib}/PAR/*
96 %exclude %{perl_vendorlib}/PAR/*.pod
97 %{_mandir}/man?/*
This page took 0.089534 seconds and 4 git commands to generate.