]> git.pld-linux.org Git - packages/perl-Net-XWhois.git/blob - perl-Net-XWhois.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-XWhois.git] / perl-Net-XWhois.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Net
6 %define         pnam    XWhois
7 Summary:        Net::XWhois - whois client Interface for Perl5
8 Summary(pl.UTF-8):      Net::XWhois - klient whois dla Perla 5
9 Name:           perl-Net-XWhois
10 Version:        0.90
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1c0394d6a4b5bd05d8686b0a0dc18999
17 URL:            http://search.cpan.org/dist/Net-XWhois/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Net::XWhois class provides a generic client framework for doing
25 whois queries and parsing server response.
26
27 %description -l pl.UTF-8
28 Klasa Net::XWhois udostępnia podstawowy szkielet klienta wykonującego
29 zapytania whois i przetwarzającego odpowiedzi serwera.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make}
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47 cp -p examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes TODO
55 %{perl_vendorlib}/Net/XWhois.pm
56 %{_mandir}/man3/*
57 %{_examplesdir}/%{name}-%{version}
This page took 0.068537 seconds and 4 git commands to generate.