]> git.pld-linux.org Git - packages/perl-Net-XMPP.git/blob - perl-Net-XMPP.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-XMPP.git] / perl-Net-XMPP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test", tests require network connectivity
4 #
5 %define         pdir    Net
6 %define         pnam    XMPP
7 Summary:        Net::XMPP - XMPP Perl library
8 Summary(pl.UTF-8):      Net::XMPP - biblioteka Perla XMPP
9 Name:           perl-Net-XMPP
10 Version:        1.05
11 Release:        1
12 # and somewhere mentioned as "perl itself"
13 License:        LGPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6fdfeecde1b7eea1a24413e6557a97e2
17 URL:            http://search.cpan.org/dist/Net-XMPP/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-LWP-Online
22 BuildRequires:  perl-XML-Stream >= 1.22
23 BuildRequires:  perl-YAML-Tiny
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Net::XMPP is a convenient tool to use for any Perl script that would
30 like to utilize the XMPP Instant Messaging protocol. While not a
31 client in and of itself, it provides all of the necessary back-end
32 functions to make a CGI client or command-line perl client feasible
33 and easy to use. Net::XMPP is a wrapper around the rest of the
34 official Net::XMPP::xxxxxx packages.
35
36 %description -l pl.UTF-8
37 Net::XMPP to wygodne narzędzie do używania w dowolnym skrypcie
38 perlowym mającym używać protokołu XMPP Instant Messaging. O ile
39 biblioteka ta nie jest klientem samym w sobie, dostarcza wszystkich
40 funkcji backendu potrzebnych do zrobienia klienta CGI lub działającego
41 z linii poleceń. Net::XMPP to wrapper dla reszty oficjalnych pakietów
42 Net::XMPP::xxxxxx.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46 # avoid online tests
47 mv t/2_client_jabberd1.4.t t/2_client_jabberd1.4.t_
48 mv t/3_client_jabberd2.t t/3_client_jabberd2.t_
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc CHANGES README
70 %{perl_vendorlib}/Net/XMPP.pm
71 %{perl_vendorlib}/Net/XMPP
72 %{_mandir}/man3/*
This page took 0.049047 seconds and 3 git commands to generate.