- up to 1.34
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
index 6ce96f909915cd5e8185c4dbbeb19860124178bf..30d993761328d055b7b2fefa03e5808ddd4fef6c 100644 (file)
@@ -8,30 +8,44 @@
 Summary:       Net::SSH::Perl - Perl client Interface to SSH
 Summary(pl.UTF-8):     Net::SSH::Perl - perlowy interfejs kliencki do SSH
 Name:          perl-Net-SSH-Perl
-Version:       1.30
+Version:       1.34
 Release:       0.1
 # same as perl
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-# Source0-md5: 063f3dc93a4fe6108b068b6d6097992d
+# Source0-md5: 5b6d60e459707058e856c45c30e96e53
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
 %if %{with tests}
-# just taken from Makefile; probably not all are required for tests...
 BuildRequires: perl-Convert-PEM >= 0.05
 BuildRequires: perl-Crypt-DH >= 0.01
 BuildRequires: perl-Crypt-DSA >= 0.11
 BuildRequires: perl-Digest-HMAC
 BuildRequires: perl-Digest-MD5
-BuildRequires: perl-Digest-SHA1
+BuildRequires: perl-Digest-SHA1 >= 2.10
 BuildRequires: perl-Math-GMP >= 1.04
 BuildRequires: perl-Math-Pari >= 2.001804
 BuildRequires: perl-MIME-Base64
 BuildRequires: perl-Scalar-List-Utils
 BuildRequires: perl-String-CRC32 >= 1.2
 %endif
+Requires:      perl-Convert-PEM >= 0.05
+Requires:      perl-Crypt-Blowfish
+Requires:      perl-Crypt-DES
+Requires:      perl-Crypt-DH >= 0.01
+Requires:      perl-Crypt-DSA >= 0.11
+Requires:      perl-Crypt-IDEA
 Requires:      perl-Crypt-RSA
+Requires:      perl-Digest-BubbleBabble
+Requires:      perl-Digest-HMAC
+Requires:      perl-Digest-MD5
+Requires:      perl-Digest-SHA1 >= 2.10
+Requires:      perl-Math-GMP >= 1.04
+Requires:      perl-Math-Pari >= 2.001804
+Requires:      perl-MIME-Base64
+Requires:      perl-Scalar-List-Utils
+Requires:      perl-String-CRC32 >= 1.2
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
This page took 0.041407 seconds and 4 git commands to generate.