]> git.pld-linux.org Git - packages/perl-Net-SSH-Perl.git/blob - perl-Net-SSH-Perl.spec
- file mode fix
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Net
6 %define         pnam    SSH-Perl
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Net::SSH::Perl - Perl client Interface to SSH
9 Summary(pl.UTF-8):      Net::SSH::Perl - perlowy interfejs kliencki do SSH
10 Name:           perl-Net-SSH-Perl
11 Version:        2.14
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  f831bc57d845da9343da7b8d5a755847
18 URL:            http://search.cpan.org/dist/Net-SSH-Perl/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Convert-PEM >= 0.05
23 BuildRequires:  perl-Crypt-DH >= 0.01
24 BuildRequires:  perl-Crypt-DSA >= 0.11
25 BuildRequires:  perl-Digest-HMAC
26 BuildRequires:  perl-Digest-MD5
27 BuildRequires:  perl-Digest-SHA1 >= 2.10
28 BuildRequires:  perl-MIME-Base64
29 BuildRequires:  perl-Math-GMP >= 1.04
30 BuildRequires:  perl-Math-Pari >= 2.001804
31 BuildRequires:  perl-String-CRC32 >= 1.2
32 %endif
33 Requires:       perl-Convert-PEM >= 0.05
34 Requires:       perl-Crypt-Blowfish
35 Requires:       perl-Crypt-DES
36 Requires:       perl-Crypt-DH >= 0.01
37 Requires:       perl-Crypt-DSA >= 0.11
38 Requires:       perl-Crypt-IDEA
39 Requires:       perl-Crypt-RSA
40 Requires:       perl-Digest-BubbleBabble
41 Requires:       perl-Digest-HMAC
42 Requires:       perl-Digest-MD5
43 Requires:       perl-Digest-SHA1 >= 2.10
44 Requires:       perl-MIME-Base64
45 Requires:       perl-Math-GMP >= 1.04
46 Requires:       perl-Math-Pari >= 2.001804
47 Requires:       perl-String-CRC32 >= 1.2
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Net::SSH::Perl is an all-Perl module implementing an SSH (Secure
52 Shell) client. It is compatible with both the SSH-1 and SSH-2
53 protocols.
54
55 %description -l pl.UTF-8
56 Net::SSH::Perl to napisany w całości w Perlu moduł implementujący
57 klienta SSH (Secure Shell). Jest kompatybilny z protokołami zarówno
58 SSH-1 jak i SSH-2.
59
60 %prep
61 %setup -q -n %{pdir}-%{pnam}-%{version}
62
63 %build
64 PERL_MM_USE_DEFAULT=1 %{__perl} Makefile.PL \
65         INSTALLDIRS=vendor
66 %{__make}
67
68 %{?with_tests:%{__make} test}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
77 cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc Changes ToDo
85 %dir %{perl_vendorarch}/auto/Net/SSH
86 %dir %{perl_vendorarch}/auto/Net/SSH/Perl
87 %dir %{perl_vendorarch}/Net/SSH
88 %attr(755,root,root) %{perl_vendorarch}/auto/Net/SSH/Perl/Perl.so
89 %{perl_vendorarch}/Net/SSH/*.pm
90 %{perl_vendorarch}/Net/SSH/Perl
91 %{_mandir}/man3/*
92 %{_examplesdir}/%{name}-%{version}
This page took 0.050369 seconds and 3 git commands to generate.