]> git.pld-linux.org Git - packages/perl-Net-SSH-Perl.git/blob - perl-Net-SSH-Perl.spec
perl 5.38.0 rebuild
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Net
6 %define         pnam    SSH-Perl
7 Summary:        Net::SSH::Perl - Perl client Interface to SSH
8 Summary(pl.UTF-8):      Net::SSH::Perl - perlowy interfejs kliencki do SSH
9 Name:           perl-Net-SSH-Perl
10 Version:        2.14
11 Release:        5
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f831bc57d845da9343da7b8d5a755847
17 URL:            http://search.cpan.org/dist/Net-SSH-Perl/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Convert-PEM >= 0.05
22 BuildRequires:  perl-Crypt-DH >= 0.01
23 BuildRequires:  perl-Crypt-DSA >= 0.11
24 BuildRequires:  perl-CryptX >= 0.066
25 BuildRequires:  perl-Digest-HMAC
26 BuildRequires:  perl-Digest-MD5
27 BuildRequires:  perl-Digest-SHA1 >= 2.10
28 BuildRequires:  perl-File-HomeDir
29 BuildRequires:  perl-MIME-Base64
30 BuildRequires:  perl-Math-GMP >= 1.04
31 BuildRequires:  perl-Math-Pari >= 2.001804
32 BuildRequires:  perl-String-CRC32 >= 1.2
33 %endif
34 Requires:       perl-Convert-PEM >= 0.05
35 Requires:       perl-Crypt-Blowfish
36 Requires:       perl-Crypt-DES
37 Requires:       perl-Crypt-DH >= 0.01
38 Requires:       perl-Crypt-DSA >= 0.11
39 Requires:       perl-Crypt-IDEA
40 Requires:       perl-Crypt-RSA
41 Requires:       perl-Digest-BubbleBabble
42 Requires:       perl-Digest-HMAC
43 Requires:       perl-Digest-MD5
44 Requires:       perl-Digest-SHA1 >= 2.10
45 Requires:       perl-MIME-Base64
46 Requires:       perl-Math-GMP >= 1.04
47 Requires:       perl-Math-Pari >= 2.001804
48 Requires:       perl-String-CRC32 >= 1.2
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Net::SSH::Perl is an all-Perl module implementing an SSH (Secure
53 Shell) client. It is compatible with both the SSH-1 and SSH-2
54 protocols.
55
56 %description -l pl.UTF-8
57 Net::SSH::Perl to napisany w całości w Perlu moduł implementujący
58 klienta SSH (Secure Shell). Jest kompatybilny z protokołami zarówno
59 SSH-1 jak i SSH-2.
60
61 %prep
62 %setup -q -n %{pdir}-%{pnam}-%{version}
63
64 %build
65 PERL_MM_USE_DEFAULT=1 %{__perl} Makefile.PL \
66         INSTALLDIRS=vendor
67 %{__make}
68
69 %{?with_tests:%{__make} test}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78 cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc Changes ToDo
86 %dir %{perl_vendorarch}/auto/Net/SSH
87 %dir %{perl_vendorarch}/auto/Net/SSH/Perl
88 %dir %{perl_vendorarch}/Net/SSH
89 %attr(755,root,root) %{perl_vendorarch}/auto/Net/SSH/Perl/Perl.so
90 %{perl_vendorarch}/Net/SSH/*.pm
91 %{perl_vendorarch}/Net/SSH/Perl
92 %{_mandir}/man3/*
93 %{_examplesdir}/%{name}-%{version}
This page took 0.077653 seconds and 3 git commands to generate.