]> git.pld-linux.org Git - packages/perl-Net-SSH-Perl.git/blob - perl-Net-SSH-Perl.spec
- up to 1.29, rel 0.1 builds here
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    SSH-Perl
8 Summary:        Net::SSH::Perl - Perl client Interface to SSH
9 Summary(pl):    Net::SSH::Perl - perlowy interfejs kliencki do SSH
10 Name:           perl-Net-SSH-Perl
11 Version:        1.29
12 Release:        0.1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  a7081d98a0dd96706805778b4935a1f4
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 # just taken from Makefile; probably not all are required for tests...
22 BuildRequires:  perl-Convert-PEM >= 0.05
23 BuildRequires:  perl-Crypt-DH >= 0.01
24 BuildRequires:  perl-Crypt-DSA >= 0.11
25 BuildRequires:  perl-Digest-HMAC
26 BuildRequires:  perl-Digest-MD5
27 BuildRequires:  perl-Digest-SHA1
28 BuildRequires:  perl-Math-GMP >= 1.04
29 BuildRequires:  perl-Math-Pari >= 2.001804
30 BuildRequires:  perl-MIME-Base64
31 BuildRequires:  perl-Scalar-List-Utils
32 BuildRequires:  perl-String-CRC32 >= 1.2
33 %endif
34 Requires:       perl-Crypt-RSA
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Net::SSH::Perl is an all-Perl module implementing an SSH (Secure
40 Shell) client. It is compatible with both the SSH-1 and SSH-2
41 protocols.
42
43 %description -l pl
44 Net::SSH::Perl to napisany w ca³o¶ci w Perlu modu³ implementuj±cy
45 klienta SSH (Secure Shell). Jest kompatybilny z protoko³ami zarówno
46 SSH-1 jak i SSH-2.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"Perl::Net::SSH::Perl")' \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65 cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes ToDo
73 %dir %{perl_vendorlib}/Net/SSH
74 %{perl_vendorlib}/Net/SSH/*.pm
75 %{perl_vendorlib}/Net/SSH/Perl
76 %{_mandir}/man3/*
77 %{_examplesdir}/%{name}-%{version}
This page took 0.071474 seconds and 3 git commands to generate.