]> git.pld-linux.org Git - packages/perl-Net-SSH-Perl.git/blob - perl-Net-SSH-Perl.spec
7390954c044ae7f1e3c0dc011cb31b1753aa5bda
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Net
7 %define pnam    SSH-Perl
8 Summary:        Net::SSH::Perl - Perl client Interface to SSH
9 Summary(pl):    Net::SSH::Perl - perlowy interfejs kliencki do SSH
10 Name:           perl-Net-SSH-Perl
11 Version:        1.25
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4022c3de719f6b3a1b3ad389ab492754
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 # just taken from Makefile; probably not all are required for tests...
22 BuildRequires:  perl-Convert-PEM >= 0.05
23 BuildRequires:  perl-Crypt-DH    >= 0.01
24 BuildRequires:  perl-Crypt-DSA   >= 0.11
25 BuildRequires:  perl-Digest-HMAC
26 BuildRequires:  perl-Digest-MD5
27 BuildRequires:  perl-Digest-SHA1
28 BuildRequires:  perl-Math-GMP  >= 1.04
29 BuildRequires:  perl-Math-Pari >= 2.001804
30 BuildRequires:  perl-MIME-Base64
31 BuildRequires:  perl-Scalar-List-Utils
32 BuildRequires:  perl-String-CRC32 >= 1.2
33 %endif
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Net::SSH::Perl is an all-Perl module implementing an SSH (Secure
39 Shell) client. It is compatible with both the SSH-1 and SSH-2
40 protocols.
41
42 %description -l pl
43 Net::SSH::Perl to napisany w ca³o¶ci w Perlu modu³ implementuj±cy
44 klienta SSH (Secure Shell). Jest kompatybilny z protoko³ami zarówno
45 SSH-1 jak i SSH-2.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"Perl::Net::SSH::Perl")' \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes ToDo
72 %{perl_vendorlib}/Net/SSH/*.pm
73 %{perl_vendorlib}/Net/SSH/Perl
74 %{_mandir}/man3/*
75 %{_examplesdir}/%{name}-%{version}
This page took 0.044757 seconds and 2 git commands to generate.