]> git.pld-linux.org Git - packages/perl-Net-SSH-Perl.git/blob - perl-Net-SSH-Perl.spec
30d993761328d055b7b2fefa03e5808ddd4fef6c
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    SSH-Perl
8 Summary:        Net::SSH::Perl - Perl client Interface to SSH
9 Summary(pl.UTF-8):      Net::SSH::Perl - perlowy interfejs kliencki do SSH
10 Name:           perl-Net-SSH-Perl
11 Version:        1.34
12 Release:        0.1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  5b6d60e459707058e856c45c30e96e53
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Convert-PEM >= 0.05
22 BuildRequires:  perl-Crypt-DH >= 0.01
23 BuildRequires:  perl-Crypt-DSA >= 0.11
24 BuildRequires:  perl-Digest-HMAC
25 BuildRequires:  perl-Digest-MD5
26 BuildRequires:  perl-Digest-SHA1 >= 2.10
27 BuildRequires:  perl-Math-GMP >= 1.04
28 BuildRequires:  perl-Math-Pari >= 2.001804
29 BuildRequires:  perl-MIME-Base64
30 BuildRequires:  perl-Scalar-List-Utils
31 BuildRequires:  perl-String-CRC32 >= 1.2
32 %endif
33 Requires:       perl-Convert-PEM >= 0.05
34 Requires:       perl-Crypt-Blowfish
35 Requires:       perl-Crypt-DES
36 Requires:       perl-Crypt-DH >= 0.01
37 Requires:       perl-Crypt-DSA >= 0.11
38 Requires:       perl-Crypt-IDEA
39 Requires:       perl-Crypt-RSA
40 Requires:       perl-Digest-BubbleBabble
41 Requires:       perl-Digest-HMAC
42 Requires:       perl-Digest-MD5
43 Requires:       perl-Digest-SHA1 >= 2.10
44 Requires:       perl-Math-GMP >= 1.04
45 Requires:       perl-Math-Pari >= 2.001804
46 Requires:       perl-MIME-Base64
47 Requires:       perl-Scalar-List-Utils
48 Requires:       perl-String-CRC32 >= 1.2
49 BuildArch:      noarch
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Net::SSH::Perl is an all-Perl module implementing an SSH (Secure
54 Shell) client. It is compatible with both the SSH-1 and SSH-2
55 protocols.
56
57 %description -l pl.UTF-8
58 Net::SSH::Perl to napisany w całości w Perlu moduł implementujący
59 klienta SSH (Secure Shell). Jest kompatybilny z protokołami zarówno
60 SSH-1 jak i SSH-2.
61
62 %prep
63 %setup -q -n %{pdir}-%{pnam}-%{version}
64
65 %build
66 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"Perl::Net::SSH::Perl")' \
67         INSTALLDIRS=vendor
68 %{__make}
69
70 %{?with_tests:%{__make} test}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79 cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc Changes ToDo
87 %dir %{perl_vendorlib}/Net/SSH
88 %{perl_vendorlib}/Net/SSH/*.pm
89 %{perl_vendorlib}/Net/SSH/Perl
90 %{_mandir}/man3/*
91 %{_examplesdir}/%{name}-%{version}
This page took 0.078463 seconds and 3 git commands to generate.