]> git.pld-linux.org Git - packages/perl-Net-SSH-Perl.git/blob - perl-Net-SSH-Perl.spec
08dc444faebedf4e0754d3bb497827243f5944ce
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Net
6 %define         pnam    SSH-Perl
7 Summary:        Net::SSH::Perl - Perl client Interface to SSH
8 Summary(pl.UTF-8):      Net::SSH::Perl - perlowy interfejs kliencki do SSH
9 Name:           perl-Net-SSH-Perl
10 Version:        2.14
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f831bc57d845da9343da7b8d5a755847
17 URL:            http://search.cpan.org/dist/Net-SSH-Perl/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Convert-PEM >= 0.05
22 BuildRequires:  perl-Crypt-DH >= 0.01
23 BuildRequires:  perl-Crypt-DSA >= 0.11
24 BuildRequires:  perl-Digest-HMAC
25 BuildRequires:  perl-Digest-MD5
26 BuildRequires:  perl-Digest-SHA1 >= 2.10
27 BuildRequires:  perl-MIME-Base64
28 BuildRequires:  perl-Math-GMP >= 1.04
29 BuildRequires:  perl-Math-Pari >= 2.001804
30 BuildRequires:  perl-String-CRC32 >= 1.2
31 %endif
32 Requires:       perl-Convert-PEM >= 0.05
33 Requires:       perl-Crypt-Blowfish
34 Requires:       perl-Crypt-DES
35 Requires:       perl-Crypt-DH >= 0.01
36 Requires:       perl-Crypt-DSA >= 0.11
37 Requires:       perl-Crypt-IDEA
38 Requires:       perl-Crypt-RSA
39 Requires:       perl-Digest-BubbleBabble
40 Requires:       perl-Digest-HMAC
41 Requires:       perl-Digest-MD5
42 Requires:       perl-Digest-SHA1 >= 2.10
43 Requires:       perl-MIME-Base64
44 Requires:       perl-Math-GMP >= 1.04
45 Requires:       perl-Math-Pari >= 2.001804
46 Requires:       perl-String-CRC32 >= 1.2
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Net::SSH::Perl is an all-Perl module implementing an SSH (Secure
51 Shell) client. It is compatible with both the SSH-1 and SSH-2
52 protocols.
53
54 %description -l pl.UTF-8
55 Net::SSH::Perl to napisany w całości w Perlu moduł implementujący
56 klienta SSH (Secure Shell). Jest kompatybilny z protokołami zarówno
57 SSH-1 jak i SSH-2.
58
59 %prep
60 %setup -q -n %{pdir}-%{pnam}-%{version}
61
62 %build
63 PERL_MM_USE_DEFAULT=1 %{__perl} Makefile.PL \
64         INSTALLDIRS=vendor
65 %{__make}
66
67 %{?with_tests:%{__make} test}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
76 cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc Changes ToDo
84 %dir %{perl_vendorarch}/auto/Net/SSH
85 %dir %{perl_vendorarch}/auto/Net/SSH/Perl
86 %dir %{perl_vendorarch}/Net/SSH
87 %attr(755,root,root) %{perl_vendorarch}/auto/Net/SSH/Perl/Perl.so
88 %{perl_vendorarch}/Net/SSH/*.pm
89 %{perl_vendorarch}/Net/SSH/Perl
90 %{_mandir}/man3/*
91 %{_examplesdir}/%{name}-%{version}
This page took 0.040599 seconds and 3 git commands to generate.