]> git.pld-linux.org Git - packages/perl-Net-SSH-Perl.git/blame_incremental - perl-Net-SSH-Perl.spec
use generic url
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define pdir Net
6%define pnam SSH-Perl
7%include /usr/lib/rpm/macros.perl
8Summary: Net::SSH::Perl - Perl client Interface to SSH
9Summary(pl.UTF-8): Net::SSH::Perl - perlowy interfejs kliencki do SSH
10Name: perl-Net-SSH-Perl
11Version: 1.34
12Release: 3
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: 5b6d60e459707058e856c45c30e96e53
18URL: http://search.cpan.org/dist/Net-SSH-Perl/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22BuildRequires: perl-Convert-PEM >= 0.05
23BuildRequires: perl-Crypt-DH >= 0.01
24BuildRequires: perl-Crypt-DSA >= 0.11
25BuildRequires: perl-Digest-HMAC
26BuildRequires: perl-Digest-MD5
27BuildRequires: perl-Digest-SHA1 >= 2.10
28BuildRequires: perl-MIME-Base64
29BuildRequires: perl-Math-GMP >= 1.04
30BuildRequires: perl-Math-Pari >= 2.001804
31BuildRequires: perl-String-CRC32 >= 1.2
32%endif
33Requires: perl-Convert-PEM >= 0.05
34Requires: perl-Crypt-Blowfish
35Requires: perl-Crypt-DES
36Requires: perl-Crypt-DH >= 0.01
37Requires: perl-Crypt-DSA >= 0.11
38Requires: perl-Crypt-IDEA
39Requires: perl-Crypt-RSA
40Requires: perl-Digest-BubbleBabble
41Requires: perl-Digest-HMAC
42Requires: perl-Digest-MD5
43Requires: perl-Digest-SHA1 >= 2.10
44Requires: perl-MIME-Base64
45Requires: perl-Math-GMP >= 1.04
46Requires: perl-Math-Pari >= 2.001804
47Requires: perl-String-CRC32 >= 1.2
48BuildArch: noarch
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52Net::SSH::Perl is an all-Perl module implementing an SSH (Secure
53Shell) client. It is compatible with both the SSH-1 and SSH-2
54protocols.
55
56%description -l pl.UTF-8
57Net::SSH::Perl to napisany w całości w Perlu moduł implementujący
58klienta SSH (Secure Shell). Jest kompatybilny z protokołami zarówno
59SSH-1 jak i SSH-2.
60
61%prep
62%setup -q -n %{pdir}-%{pnam}-%{version}
63
64%build
65%{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"Perl::Net::SSH::Perl")' \
66 INSTALLDIRS=vendor
67%{__make}
68
69%{?with_tests:%{__make} test}
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74%{__make} install \
75 DESTDIR=$RPM_BUILD_ROOT
76
77install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%files
84%defattr(644,root,root,755)
85%doc Changes ToDo
86%dir %{perl_vendorlib}/Net/SSH
87%{perl_vendorlib}/Net/SSH/*.pm
88%{perl_vendorlib}/Net/SSH/Perl
89%{_mandir}/man3/*
90%{_examplesdir}/%{name}-%{version}
This page took 0.074286 seconds and 4 git commands to generate.