]> git.pld-linux.org Git - packages/perl-Net-SSH-Perl.git/blame_incremental - perl-Net-SSH-Perl.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define pdir Net
6%define pnam SSH-Perl
7Summary: Net::SSH::Perl - Perl client Interface to SSH
8Summary(pl.UTF-8): Net::SSH::Perl - perlowy interfejs kliencki do SSH
9Name: perl-Net-SSH-Perl
10Version: 2.14
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: f831bc57d845da9343da7b8d5a755847
17URL: http://search.cpan.org/dist/Net-SSH-Perl/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl-Convert-PEM >= 0.05
22BuildRequires: perl-Crypt-DH >= 0.01
23BuildRequires: perl-Crypt-DSA >= 0.11
24BuildRequires: perl-Digest-HMAC
25BuildRequires: perl-Digest-MD5
26BuildRequires: perl-Digest-SHA1 >= 2.10
27BuildRequires: perl-MIME-Base64
28BuildRequires: perl-Math-GMP >= 1.04
29BuildRequires: perl-Math-Pari >= 2.001804
30BuildRequires: perl-String-CRC32 >= 1.2
31%endif
32Requires: perl-Convert-PEM >= 0.05
33Requires: perl-Crypt-Blowfish
34Requires: perl-Crypt-DES
35Requires: perl-Crypt-DH >= 0.01
36Requires: perl-Crypt-DSA >= 0.11
37Requires: perl-Crypt-IDEA
38Requires: perl-Crypt-RSA
39Requires: perl-Digest-BubbleBabble
40Requires: perl-Digest-HMAC
41Requires: perl-Digest-MD5
42Requires: perl-Digest-SHA1 >= 2.10
43Requires: perl-MIME-Base64
44Requires: perl-Math-GMP >= 1.04
45Requires: perl-Math-Pari >= 2.001804
46Requires: perl-String-CRC32 >= 1.2
47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49%description
50Net::SSH::Perl is an all-Perl module implementing an SSH (Secure
51Shell) client. It is compatible with both the SSH-1 and SSH-2
52protocols.
53
54%description -l pl.UTF-8
55Net::SSH::Perl to napisany w całości w Perlu moduł implementujący
56klienta SSH (Secure Shell). Jest kompatybilny z protokołami zarówno
57SSH-1 jak i SSH-2.
58
59%prep
60%setup -q -n %{pdir}-%{pnam}-%{version}
61
62%build
63PERL_MM_USE_DEFAULT=1 %{__perl} Makefile.PL \
64 INSTALLDIRS=vendor
65%{__make}
66
67%{?with_tests:%{__make} test}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72%{__make} install \
73 DESTDIR=$RPM_BUILD_ROOT
74
75install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
76cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%files
82%defattr(644,root,root,755)
83%doc Changes ToDo
84%dir %{perl_vendorarch}/auto/Net/SSH
85%dir %{perl_vendorarch}/auto/Net/SSH/Perl
86%dir %{perl_vendorarch}/Net/SSH
87%attr(755,root,root) %{perl_vendorarch}/auto/Net/SSH/Perl/Perl.so
88%{perl_vendorarch}/Net/SSH/*.pm
89%{perl_vendorarch}/Net/SSH/Perl
90%{_mandir}/man3/*
91%{_examplesdir}/%{name}-%{version}
This page took 0.02924 seconds and 4 git commands to generate.