]> git.pld-linux.org Git - packages/perl-Net-SSH-Perl.git/blame_incremental - perl-Net-SSH-Perl.spec
- don't require perl-Scalar-List-Utils, it's in perl-modules
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Net
7%define pnam SSH-Perl
8Summary: Net::SSH::Perl - Perl client Interface to SSH
9Summary(pl.UTF-8): Net::SSH::Perl - perlowy interfejs kliencki do SSH
10Name: perl-Net-SSH-Perl
11Version: 1.34
12Release: 3
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: 5b6d60e459707058e856c45c30e96e53
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl-Convert-PEM >= 0.05
22BuildRequires: perl-Crypt-DH >= 0.01
23BuildRequires: perl-Crypt-DSA >= 0.11
24BuildRequires: perl-Digest-HMAC
25BuildRequires: perl-Digest-MD5
26BuildRequires: perl-Digest-SHA1 >= 2.10
27BuildRequires: perl-Math-GMP >= 1.04
28BuildRequires: perl-Math-Pari >= 2.001804
29BuildRequires: perl-MIME-Base64
30BuildRequires: perl-String-CRC32 >= 1.2
31%endif
32Requires: perl-Convert-PEM >= 0.05
33Requires: perl-Crypt-Blowfish
34Requires: perl-Crypt-DES
35Requires: perl-Crypt-DH >= 0.01
36Requires: perl-Crypt-DSA >= 0.11
37Requires: perl-Crypt-IDEA
38Requires: perl-Crypt-RSA
39Requires: perl-Digest-BubbleBabble
40Requires: perl-Digest-HMAC
41Requires: perl-Digest-MD5
42Requires: perl-Digest-SHA1 >= 2.10
43Requires: perl-Math-GMP >= 1.04
44Requires: perl-Math-Pari >= 2.001804
45Requires: perl-MIME-Base64
46Requires: perl-String-CRC32 >= 1.2
47BuildArch: noarch
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51Net::SSH::Perl is an all-Perl module implementing an SSH (Secure
52Shell) client. It is compatible with both the SSH-1 and SSH-2
53protocols.
54
55%description -l pl.UTF-8
56Net::SSH::Perl to napisany w całości w Perlu moduł implementujący
57klienta SSH (Secure Shell). Jest kompatybilny z protokołami zarówno
58SSH-1 jak i SSH-2.
59
60%prep
61%setup -q -n %{pdir}-%{pnam}-%{version}
62
63%build
64%{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"Perl::Net::SSH::Perl")' \
65 INSTALLDIRS=vendor
66%{__make}
67
68%{?with_tests:%{__make} test}
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73%{__make} install \
74 DESTDIR=$RPM_BUILD_ROOT
75
76install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
77cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%files
83%defattr(644,root,root,755)
84%doc Changes ToDo
85%dir %{perl_vendorlib}/Net/SSH
86%{perl_vendorlib}/Net/SSH/*.pm
87%{perl_vendorlib}/Net/SSH/Perl
88%{_mandir}/man3/*
89%{_examplesdir}/%{name}-%{version}
This page took 0.054835 seconds and 4 git commands to generate.