]> git.pld-linux.org Git - packages/perl-Net-SSH-Perl.git/blame_incremental - perl-Net-SSH-Perl.spec
rebuild with perl 5.32
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define pdir Net
6%define pnam SSH-Perl
7Summary: Net::SSH::Perl - Perl client Interface to SSH
8Summary(pl.UTF-8): Net::SSH::Perl - perlowy interfejs kliencki do SSH
9Name: perl-Net-SSH-Perl
10Version: 2.14
11Release: 2
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: f831bc57d845da9343da7b8d5a755847
17URL: http://search.cpan.org/dist/Net-SSH-Perl/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl-Convert-PEM >= 0.05
22BuildRequires: perl-Crypt-DH >= 0.01
23BuildRequires: perl-Crypt-DSA >= 0.11
24BuildRequires: perl-CryptX >= 0.066
25BuildRequires: perl-Digest-HMAC
26BuildRequires: perl-Digest-MD5
27BuildRequires: perl-Digest-SHA1 >= 2.10
28BuildRequires: perl-File-HomeDir
29BuildRequires: perl-MIME-Base64
30BuildRequires: perl-Math-GMP >= 1.04
31BuildRequires: perl-Math-Pari >= 2.001804
32BuildRequires: perl-String-CRC32 >= 1.2
33%endif
34Requires: perl-Convert-PEM >= 0.05
35Requires: perl-Crypt-Blowfish
36Requires: perl-Crypt-DES
37Requires: perl-Crypt-DH >= 0.01
38Requires: perl-Crypt-DSA >= 0.11
39Requires: perl-Crypt-IDEA
40Requires: perl-Crypt-RSA
41Requires: perl-Digest-BubbleBabble
42Requires: perl-Digest-HMAC
43Requires: perl-Digest-MD5
44Requires: perl-Digest-SHA1 >= 2.10
45Requires: perl-MIME-Base64
46Requires: perl-Math-GMP >= 1.04
47Requires: perl-Math-Pari >= 2.001804
48Requires: perl-String-CRC32 >= 1.2
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52Net::SSH::Perl is an all-Perl module implementing an SSH (Secure
53Shell) client. It is compatible with both the SSH-1 and SSH-2
54protocols.
55
56%description -l pl.UTF-8
57Net::SSH::Perl to napisany w całości w Perlu moduł implementujący
58klienta SSH (Secure Shell). Jest kompatybilny z protokołami zarówno
59SSH-1 jak i SSH-2.
60
61%prep
62%setup -q -n %{pdir}-%{pnam}-%{version}
63
64%build
65PERL_MM_USE_DEFAULT=1 %{__perl} Makefile.PL \
66 INSTALLDIRS=vendor
67%{__make}
68
69%{?with_tests:%{__make} test}
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74%{__make} install \
75 DESTDIR=$RPM_BUILD_ROOT
76
77install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%files
84%defattr(644,root,root,755)
85%doc Changes ToDo
86%dir %{perl_vendorarch}/auto/Net/SSH
87%dir %{perl_vendorarch}/auto/Net/SSH/Perl
88%dir %{perl_vendorarch}/Net/SSH
89%attr(755,root,root) %{perl_vendorarch}/auto/Net/SSH/Perl/Perl.so
90%{perl_vendorarch}/Net/SSH/*.pm
91%{perl_vendorarch}/Net/SSH/Perl
92%{_mandir}/man3/*
93%{_examplesdir}/%{name}-%{version}
This page took 0.022641 seconds and 4 git commands to generate.