- up to 1.29, rel 0.1 builds here
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
CommitLineData
ac0d4d46 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
f5364129 6%define pdir Net
7%define pnam SSH-Perl
ac0d4d46 8Summary: Net::SSH::Perl - Perl client Interface to SSH
e69968ab 9Summary(pl): Net::SSH::Perl - perlowy interfejs kliencki do SSH
ac0d4d46 10Name: perl-Net-SSH-Perl
7a7e40dc
MP
11Version: 1.29
12Release: 0.1
ac0d4d46 13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
7a7e40dc 17# Source0-md5: a7081d98a0dd96706805778b4935a1f4
e69968ab 18BuildRequires: perl-devel >= 1:5.8.0
ac0d4d46 19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21# just taken from Makefile; probably not all are required for tests...
22BuildRequires: perl-Convert-PEM >= 0.05
446c8888 23BuildRequires: perl-Crypt-DH >= 0.01
24BuildRequires: perl-Crypt-DSA >= 0.11
ac0d4d46 25BuildRequires: perl-Digest-HMAC
26BuildRequires: perl-Digest-MD5
27BuildRequires: perl-Digest-SHA1
446c8888 28BuildRequires: perl-Math-GMP >= 1.04
ac0d4d46 29BuildRequires: perl-Math-Pari >= 2.001804
30BuildRequires: perl-MIME-Base64
31BuildRequires: perl-Scalar-List-Utils
32BuildRequires: perl-String-CRC32 >= 1.2
33%endif
4dcb086f 34Requires: perl-Crypt-RSA
ac0d4d46 35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
e69968ab
JB
39Net::SSH::Perl is an all-Perl module implementing an SSH (Secure
40Shell) client. It is compatible with both the SSH-1 and SSH-2
41protocols.
ac0d4d46 42
e69968ab
JB
43%description -l pl
44