]> git.pld-linux.org Git - packages/perl-Net-SSH-Perl.git/blame - perl-Net-SSH-Perl.spec
- new
[packages/perl-Net-SSH-Perl.git] / perl-Net-SSH-Perl.spec
CommitLineData
ac0d4d46 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Net
7%define pnam SSH-Perl
8Summary: Net::SSH::Perl - Perl client Interface to SSH
9#Summary(pl):
10Name: perl-Net-SSH-Perl
11Version: 1.25
12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: 4022c3de719f6b3a1b3ad389ab492754
18BuildRequires: perl-devel >= 5.6
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21# just taken from Makefile; probably not all are required for tests...
22BuildRequires: perl-Convert-PEM >= 0.05
23BuildRequires: perl-Crypt-DH >= 0.01
24BuildRequires: perl-Crypt-DSA >= 0.11
25BuildRequires: perl-Digest-HMAC
26BuildRequires: perl-Digest-MD5
27BuildRequires: perl-Digest-SHA1
28BuildRequires: perl-Math-GMP >= 1.04
29BuildRequires: perl-Math-Pari >= 2.001804
30BuildRequires: perl-MIME-Base64
31BuildRequires: perl-Scalar-List-Utils
32BuildRequires: perl-String-CRC32 >= 1.2
33%endif
34BuildArch: noarch
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38I<Net::SSH::Perl> is an all-Perl module implementing an SSH (Secure Shell)
39client. It is compatible with both the SSH-1 and SSH-2 protocols.
40
41# %description -l pl
42# TODO
43
44%prep
45%setup -q -n %{pdir}-%{pnam}-%{version}
46
47%build
48%{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"Perl::Net::SSH::Perl")' \
49 INSTALLDIRS=vendor
50%{__make}
51
52%{?with_tests:%{__make} test}
53
54%install
55rm -rf $RPM_BUILD_ROOT
56
57%{__make} install \
58 DESTDIR=$RPM_BUILD_ROOT
59
60install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(644,root,root,755)
68%doc Changes ToDo
69%{perl_vendorlib}/Net/SSH/*.pm
70%{perl_vendorlib}/Net/SSH/Perl
71%{_mandir}/man3/*
72%{_examplesdir}/%{name}-%{version}
This page took 0.165725 seconds and 4 git commands to generate.