]> git.pld-linux.org Git - packages/perl-Net-SMTP-SSL.git/blob - perl-Net-SMTP-SSL.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-SMTP-SSL.git] / perl-Net-SMTP-SSL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Net
6 %define pnam    SMTP-SSL
7 Summary:        Net::SMTP::SSL - An SMTP client supporting SSL
8 Summary(pl.UTF-8):      Net::SMTP::SSL - klient SMTP obsługujący SSL
9 Name:           perl-Net-SMTP-SSL
10 Version:        1.04
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  62b49c961043898b43b041dafbc1b389
17 URL:            http://search.cpan.org/dist/Net-SMTP-SSL/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-IO-Socket-SSL
22 BuildRequires:  perl-Net-SSLeay
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Net::SMTP::SSL implements the same API as Net::SMTP, but uses
29 IO::Socket::SSL for its network operations.
30
31 %description -l pl.UTF-8
32 Net::SMTP::SSL implementuje API identyczne z Net::SMTP, ale używa
33 IO::Socket::SSL do operacji sieciowych.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes
57 %{perl_vendorlib}/Net/SMTP/SSL.pm
58 %{_mandir}/man3/Net::SMTP::SSL.3pm*
This page took 0.090696 seconds and 4 git commands to generate.