]> git.pld-linux.org Git - packages/perl-Net-SCP-Expect.git/blob - perl-Net-SCP-Expect.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-SCP-Expect.git] / perl-Net-SCP-Expect.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Net
6 %define         pnam    SCP-Expect
7 Summary:        Net::SCP::Expect - Wrapper for scp that allows passwords via Expect
8 Summary(pl.UTF-8):      Net::SCP::Expect - wrapper dla scp umożliwiający podawanie haseł przez Expect
9 Name:           perl-Net-SCP-Expect
10 Version:        0.16
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a3d8f5e6a34ba3df8527aea098f64a58
17 URL:            http://search.cpan.org/dist/Net-SCP-Expect/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Net::IPv6Addr) >= 0.2
22 BuildRequires:  perl-Expect >= 1.14
23 BuildRequires:  perl-Term-ReadPassword >= 0.01
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module is simply a wrapper around the scp call. The primary
30 difference between this module and Net::SCP is that you may send a
31 password programmatically, instead of being forced to deal with
32 interactive sessions.
33
34 %description -l pl.UTF-8
35 Ten moduł jest prostym wrapperem dla wywołań scp. Główna różnica
36 między tym modułem a Net::SCP jest taka, że można programowo wysłać
37 hasło zamiast być zmuszonym do obsługi interaktywnych sesji.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc CHANGES README
61 %dir %{perl_vendorlib}/Net/SCP
62 %{perl_vendorlib}/Net/SCP/Expect.pm
63 %{_mandir}/man3/*
This page took 0.122107 seconds and 3 git commands to generate.