]> git.pld-linux.org Git - packages/perl-Net-Rendezvous-Publish.git/blob - perl-Net-Rendezvous-Publish.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-Rendezvous-Publish.git] / perl-Net-Rendezvous-Publish.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Net
6 %define pnam    Rendezvous-Publish
7 Summary:        Net::Rendezvous::Publish - publish Rendezvous services
8 Name:           perl-Net-Rendezvous-Publish
9 Version:        0.04
10 Release:        1
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  abd07bd91853f5536d6e3434c67918c3
15 URL:            http://search.cpan.org/dist/Net-Bonjour/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 %if %{with tests}
19 BuildRequires:  perl-Class-Accessor-Lvalue
20 %endif
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Net::Rendezvous::Publish - publish Rendezvous services
26
27 %prep
28 %setup -q -n %{pdir}-%{pnam}-%{version}
29
30 %build
31 %{__perl} Makefile.PL \
32         INSTALLDIRS=vendor
33 %{__make}
34
35 %{?with_tests:%{__make} test}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39
40 %{__make} install \
41         DESTDIR=$RPM_BUILD_ROOT
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %dir %{perl_vendorlib}/Net/Rendezvous/Publish
49 %dir %{perl_vendorlib}/Net/Rendezvous/Publish/Backend
50 %{perl_vendorlib}/Net/Rendezvous/Publish.pm
51 %{perl_vendorlib}/Net/Rendezvous/Publish/Service.pm
52 %{perl_vendorlib}/Net/Rendezvous/Publish/Backend/Null.pm
53 %{_mandir}/man3/*
This page took 0.07302 seconds and 4 git commands to generate.