]> git.pld-linux.org Git - packages/perl-Net-PcapUtils.git/blob - perl-Net-PcapUtils.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-PcapUtils.git] / perl-Net-PcapUtils.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4                         # require UID=0
5
6 %define         pdir    Net
7 %define         pnam    PcapUtils
8 Summary:        Perl Net::PcapUtils module
9 Summary(pl.UTF-8):      Moduł perla Net::PcapUtils
10 Name:           perl-Net-PcapUtils
11 Version:        0.01
12 Release:        6
13 License:        free
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  eeba67266dbe155b504df3c2de1d657f
17 URL:            http://search.cpan.org/dist/Net-PcapUtils/
18 BuildRequires:  libpcap-devel
19 BuildRequires:  perl-Net-Pcap
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module provides some code to abstract away some of the messier
27 parts of using the Net::Pcap library. The idea is to be able to write
28 "one-liner" type scripts for packet capture without getting bogged
29 down in the initialisation code. This makes it possible to write very
30 compact Perl scripts involving packet capture.
31
32 %description -l pl.UTF-8
33 Ten moduł dostarcza trochę kodu by oddalić bardziej zawiłe części
34 używania biblioteki Net::Pcap. Idea jest taka, by móc pisać skrypty
35 jednolinijkowe do przechwytywania pakietów bez zakopywania się w kod
36 inicjalizujący. Pozwala to na pisanie bardzo krótkich skryptów
37 perlowych przechwytujących pakiety.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54 find $RPM_BUILD_ROOT -name .packlist | xargs -r rm -f
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README
62 %{perl_vendorlib}/%{pdir}/%{pnam}.pm
63 %{_mandir}/man3/*
This page took 0.07625 seconds and 4 git commands to generate.