]> git.pld-linux.org Git - packages/perl-Net-OAuth.git/blob - perl-Net-OAuth.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-OAuth.git] / perl-Net-OAuth.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Net
6 %define         pnam    OAuth
7 Summary:        Net::OAuth - OAuth protocol support
8 #Summary(pl.UTF-8):
9 Name:           perl-Net-OAuth
10 Version:        0.28
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/K/KG/KGRENNAN/Net-OAuth-%{version}.tar.gz
16 # Source0-md5:  336d7fb22e945f014e1bce0f49fcfad9
17 URL:            http://search.cpan.org/dist/Net-OAuth/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Class-Accessor >= 0.31
22 BuildRequires:  perl-Class-Data-Inheritable >= 0.06
23 BuildRequires:  perl-Digest-HMAC >= 1.01
24 BuildRequires:  perl-Digest-SHA1 >= 2.12
25 BuildRequires:  perl-Encode
26 BuildRequires:  perl-Test-Warn >= 0.21
27 BuildRequires:  perl-URI
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 An OAuth message is a set of key-value pairs. The following message
34 types are supported:
35 - Requests
36 - Responses
37
38 Each OAuth message type has one or more required parameters, zero or
39 more optional parameters, and most allow arbitrary parameters.
40
41 All OAuth requests must be signed by the Consumer. Responses from the
42 Service Provider, however, are not signed.
43
44 # %description -l pl.UTF-8
45 # TODO
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Build.PL \
52         destdir=$RPM_BUILD_ROOT \
53         installdirs=vendor
54 ./Build
55
56 %{?with_tests:./Build test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 ./Build install
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %{perl_vendorlib}/Net/*.pm
70 %{perl_vendorlib}/Net/OAuth
71 %{_mandir}/man3/*
This page took 0.086023 seconds and 4 git commands to generate.