]> git.pld-linux.org Git - packages/perl-Net-Interface.git/blob - perl-Net-Interface.spec
perl 5.38.0 rebuild
[packages/perl-Net-Interface.git] / perl-Net-Interface.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Net
6 %define         pnam    Interface
7 Summary:        Net::Interface - Perl extension to access network interfaces
8 Summary(pl.UTF-8):      Net::Interface - moduł umożliwiający dostęp do interfejsów sieciowych
9 Name:           perl-Net-Interface
10 Version:        1.016
11 Release:        6
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  339079deafeb8720c569bae51dac4a0d
17 Patch0:         no-dot-in-inc.patch
18 Patch1:         %{name}-iface.patch
19 URL:            http://search.cpan.org/dist/Net-Interface/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Net::Interface is designed to make the use of ifconfig(1) and friends
26 unnecessary from within Perl. It provides methods to get and set all
27 the attributes of an interface, and even create new logical or
28 physical interfaces (if your O/S supports it).
29
30 %description -l pl.UTF-8
31 Net::Interface został zaprojektowany, aby uczynić używanie ifconfig(1)
32 i spółki z poziomu Perla niepotrzebnym. Dostarcza metody do
33 odczytywania i ustawiania wszystkich atrybutów interfejsu, a nawet
34 tworzenia nowych logicznych i fizycznych interfejsów (o ile system
35 operacyjny na to pozwala).
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39 %patch0 -p1
40 %patch1 -p1
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README*
63 %{perl_vendorarch}/Net/Interface.pm
64 %dir %{perl_vendorarch}/auto/Net/Interface
65 %attr(755,root,root) %{perl_vendorarch}/auto/Net/Interface/Interface.so
66 %dir %{perl_vendorarch}/Net/Interface
67 %{perl_vendorarch}/Net/Interface/Developer.pm
68 %{perl_vendorarch}/Net/Interface/NetSymbols.pm
69 %{_mandir}/man3/*
This page took 0.153763 seconds and 4 git commands to generate.