]> git.pld-linux.org Git - packages/perl-Net-IPv6Addr.git/blob - perl-Net-IPv6Addr.spec
- initial
[packages/perl-Net-IPv6Addr.git] / perl-Net-IPv6Addr.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Net
7 %define pnam    IPv6Addr
8 Summary:        Net::IPv6Addr - check validity of IPv6 addresses
9 Summary(pl.UTF-8):      Net::IPv6Addr - sprawdza poprawność adresów IPv6
10 Name:           perl-Net-IPv6Addr
11 Version:        0.2
12 Release:        1
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  cd06f0422ddb3ac119e2ef1e27aa9339
17 URL:            http://search.cpan.org/dist/Net-IPv6Addr/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Math::Base85)
22 BuildRequires:  perl(Net::IPv4Addr)
23 %endif
24 Suggests:       perl-Math-Base85
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Net::IPv6Addr checks strings for valid IPv6 addresses, as specified in
30 RFC1884. You throw possible addresses at it, it either accepts them or
31 throws an exception.
32
33 If Math::Base85 is installed, then this module is able to process
34 addresses formatted in the style referenced by RFC1924.
35
36 %description -l pl.UTF-8
37 Net::IPv6Addr sprawdza ciągi znaków czy są
38 poprawnym adresem IPv6 tak jak zdefiniowano to w RFC1884.
39
40 We współpracy z modułem Math::Base85 moduł ten umożliwia przetworzenie
41 adresów zgodnych z formatem zdefiniowanym w RFC1924.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc ChangeLog README
65 %{perl_vendorlib}/Net/*.pm
66 %{_mandir}/man3/*
This page took 0.132287 seconds and 4 git commands to generate.