]> git.pld-linux.org Git - packages/perl-Net-IPv6Addr.git/blame_incremental - perl-Net-IPv6Addr.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-IPv6Addr.git] / perl-Net-IPv6Addr.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Net
6%define pnam IPv6Addr
7Summary: Net::IPv6Addr - check validity of IPv6 addresses
8Summary(pl.UTF-8): Net::IPv6Addr - sprawdza poprawność adresów IPv6
9Name: perl-Net-IPv6Addr
10Version: 0.2
11Release: 1
12License: GPL v1+ or Artistic
13Group: Development/Languages/Perl
14Source0: http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
15# Source0-md5: cd06f0422ddb3ac119e2ef1e27aa9339
16URL: http://search.cpan.org/dist/Net-IPv6Addr/
17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
19%if %{with tests}
20BuildRequires: perl(Math::Base85)
21BuildRequires: perl(Net::IPv4Addr)
22%endif
23Suggests: perl-Math-Base85
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28Net::IPv6Addr checks strings for valid IPv6 addresses, as specified in
29RFC1884. You throw possible addresses at it, it either accepts them or
30throws an exception.
31
32If Math::Base85 is installed, then this module is able to process
33addresses formatted in the style referenced by RFC1924.
34
35%description -l pl.UTF-8
36Net::IPv6Addr sprawdza ciągi znaków czy są
37poprawnym adresem IPv6 tak jak zdefiniowano to w RFC1884.
38
39We współpracy z modułem Math::Base85 moduł ten umożliwia przetworzenie
40adresów zgodnych z formatem zdefiniowanym w RFC1924.
41
42%prep
43%setup -q -n %{pdir}-%{pnam}-%{version}
44
45%build
46%{__perl} Makefile.PL \
47 INSTALLDIRS=vendor
48%{__make}
49
50%{?with_tests:%{__make} test}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54
55%{__make} install \
56 DESTDIR=$RPM_BUILD_ROOT
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
63%doc ChangeLog README
64%{perl_vendorlib}/Net/*.pm
65%{_mandir}/man3/*
This page took 0.074486 seconds and 4 git commands to generate.