]> git.pld-linux.org Git - packages/perl-Net-IPv6Addr.git/blame - perl-Net-IPv6Addr.spec
- initial
[packages/perl-Net-IPv6Addr.git] / perl-Net-IPv6Addr.spec
CommitLineData
ce09ae08 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Net
7%define pnam IPv6Addr
8Summary: Net::IPv6Addr - check validity of IPv6 addresses
9Summary(pl.UTF-8): Net::IPv6Addr - sprawdza poprawność adresów IPv6
10Name: perl-Net-IPv6Addr
11Version: 0.2
12Release: 1
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: cd06f0422ddb3ac119e2ef1e27aa9339
17URL: http://search.cpan.org/dist/Net-IPv6Addr/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20%if %{with tests}
21BuildRequires: perl(Math::Base85)
22BuildRequires: perl(Net::IPv4Addr)
23%endif
24Suggests: perl-Math-Base85
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29Net::IPv6Addr checks strings for valid IPv6 addresses, as specified in
30RFC1884. You throw possible addresses at it, it either accepts them or
31throws an exception.
32
33If Math::Base85 is installed, then this module is able to process
34addresses formatted in the style referenced by RFC1924.
35
36%description -l pl.UTF-8
37Net::IPv6Addr sprawdza ciągi znaków czy są
38poprawnym adresem IPv6 tak jak zdefiniowano to w RFC1884.
39
40We współpracy z modułem Math::Base85 moduł ten umożliwia przetworzenie
41adresów zgodnych z formatem zdefiniowanym w RFC1924.
42
43%prep
44%setup -q -n %{pdir}-%{pnam}-%{version}
45
46%build
47%{__perl} Makefile.PL \
48 INSTALLDIRS=vendor
49%{__make}
50
51%{?with_tests:%{__make} test}
52
53%install
54rm -rf $RPM_BUILD_ROOT
55
56%{__make} install \
57 DESTDIR=$RPM_BUILD_ROOT
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(644,root,root,755)
64%doc ChangeLog README
65%{perl_vendorlib}/Net/*.pm
66%{_mandir}/man3/*
This page took 0.12502 seconds and 4 git commands to generate.