]> git.pld-linux.org Git - packages/perl-Net-IDN-Encode.git/blob - perl-Net-IDN-Encode.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-IDN-Encode.git] / perl-Net-IDN-Encode.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Net
6 %define         pnam    IDN-Encode
7 Summary:        Encoding/decoding of Internationalized Domain Names (IDNs)
8 Summary(pl.UTF-8):      Kodowanie/dekodowanie międzynarodowych nazw domenowych (IDN)
9 Name:           perl-Net-IDN-Encode
10 Version:        2.500
11 Release:        1
12 # "same as perl"
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7e5697a38cf05ff66be96947815573da
17 URL:            http://search.cpan.org/dist/Net-IDN-Encode/
18 %if %{with tests}
19 BuildRequires:  perl-ExtUtils-CBuilder
20 BuildRequires:  perl-Test-NoWarnings
21 BuildRequires:  perl-Test-Simple
22 BuildRequires:  perl-Unicode-Normalize
23 %endif
24 BuildRequires:  perl-devel >= 1:5.8.5
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The "Net::IDN::Encode" module provides an easy-to-use interface for
31 Internationalized Domain Names (IDNs).
32
33 %description -l pl.UTF-8
34 Moduł Net::IDN::Encode dostarcza łatwego w użyciu interfejsu do
35 obsługi Międzynarodowych Nazw Domenowych (Internationalized Domain
36 Names - IDN).
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Net/IDN/*.pod
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorlib}/Net/IDN/Encode.pm
64 %{perl_vendorlib}/Net/IDN/Punycode.pm
65 %{perl_vendorlib}/Net/IDN/Punycode.xs
66 %{perl_vendorlib}/Net/IDN/Punycode
67 %{perl_vendorlib}/Net/IDN/UTS46.pm
68 %{perl_vendorlib}/Net/IDN/UTS46
69 %{_mandir}/man3/Net::IDN::Encode.3pm*
70 %{_mandir}/man3/Net::IDN::Overview.3pm*
71 %{_mandir}/man3/Net::IDN::Punycode*.3pm*
72 %{_mandir}/man3/Net::IDN::Standards.3pm*
73 %{_mandir}/man3/Net::IDN::UTS46*.3pm*
This page took 0.072591 seconds and 4 git commands to generate.