]> git.pld-linux.org Git - packages/perl-Net-FTP-Common.git/blob - perl-Net-FTP-Common.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-FTP-Common.git] / perl-Net-FTP-Common.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (uses network!)
4
5 %define         pdir    Net
6 %define         pnam    FTP-Common
7 Summary:        Net::FTP::Common - simplify common usages of Net::FTP
8 Summary(pl.UTF-8):      Net::FTP::Common - uproszczenie popularnych sposobów użycia Net::FTP
9 Name:           perl-Net-FTP-Common
10 Version:        7.0.d
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  15b1b719b5ac26a0122775c2e68c7d5c
16 URL:            http://search.cpan.org/dist/Net-FTP-Common/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(Net::FTP) >= 1
21 %endif
22 # for Net::FTP and directory
23 Requires:       perl-libnet
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module is intended to make the common uses of Net::FTP a
29 one-line, no-argument affair. In other words, you have 100%
30 programming with Net::FTP. With Net::FTP::Common you will have 95%
31 configuration and 5% programming.
32
33 %description -l pl.UTF-8
34 Ten moduł ma uczynić popularne sposoby użycia Net::FTP
35 jednolinijkowymi wywołaniami bez argumentów. Innymi słowy, przy użyciu
36 Net::FTP mamy 100% programowania. Przy użyciu Net::FTP::Common mamy
37 95% konfiguracji i 5% programowania.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56 cp -a samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc ChangeLog README
64 %{perl_vendorlib}/TestConfig.pm
65 %{perl_vendorlib}/%{pdir}/FTP/Common.pm
66 %{_mandir}/man3/*
67 %{_examplesdir}/%{name}-%{version}
This page took 0.081505 seconds and 4 git commands to generate.