]> git.pld-linux.org Git - packages/perl-Net-ARP.git/blob - perl-Net-ARP.spec
perl 5.38.0 rebuild
[packages/perl-Net-ARP.git] / perl-Net-ARP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test" (requires uid 0)
4 #
5 %define pdir    Net
6 %define pnam    ARP
7 Summary:        Perl extension for creating ARP packets
8 Summary(pl.UTF-8):      Rozszerzenie Perla do tworzenia pakietów ARP
9 Name:           perl-Net-ARP
10 Version:        1.0.6
11 Release:        16
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tgz
16 # Source0-md5:  1b71124347f23f951b96e86826af8562
17 URL:            http://search.cpan.org/dist/Net-ARP/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Net-Pcap
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module can be used to create and send ARP packets and to get the
27 MAC address of an ethernet interface or IP address.
28
29 %description -l pl.UTF-8
30 Ten moduł może być użyty do tworzenia i wysłania pakietów ARP oraz do
31 uzyskiwania adresu MAC interfejsu sieciowego lub adresu IP.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make} \
40         CC="%{__cc}" \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorarch}/Net/*.pm
58 %dir %{perl_vendorarch}/auto/Net/ARP
59 %attr(755,root,root) %{perl_vendorarch}/auto/Net/ARP/ARP.so
60 %{_mandir}/man3/*
This page took 0.119764 seconds and 3 git commands to generate.