]> git.pld-linux.org Git - packages/perl-MySQL-Diff.git/blob - perl-MySQL-Diff.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-MySQL-Diff.git] / perl-MySQL-Diff.spec
1 # TODO
2 # - active bugs: http://rt.cpan.org/Public/Dist/Display.html?Status=Active&Name=MySQL-Diff
3 #
4 # Conditional build:
5 %bcond_with     tests   # perform "make test" (requires mysql server and access to test_* tables)
6 #
7 %define         pdir    MySQL
8 %define         pnam    Diff
9 Summary:        MySQL::Diff Perl module - comparing the table structure of two MySQL databases
10 Summary(pl.UTF-8):      Moduł Perla MySQL::Diff - porównywanie struktury tabel dwóch baz danych MySQL
11 Name:           perl-MySQL-Diff
12 Version:        0.43
13 Release:        1
14 License:        GPL
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  5ca29ef5e07338fb5fa673fd298a000f
18 URL:            http://adamspiers.org/computing/mysqldiff/
19 BuildRequires:  perl-Class-MakeMethods
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  mysql-client
24 %endif
25 Requires:       perl-Class-MakeMethods
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 MySQL::Diff is Perl module for comparing the table structure of two
31 MySQL databases.
32
33 %description -l pl.UTF-8
34 MySQL::Diff to moduł Perla służący do porównywania struktury tabel
35 dwóch baz danych MySQL.
36
37 %package -n mysqldiff
38 Summary:        Perl script which compares the table definitions of two MySQL databases
39 Summary(pl.UTF-8):      Skrypt Perla porównujący definicje tabel dwóch baz danych MySQL
40 Group:          Development/Languages/Perl
41 Requires:       %{name} = %{version}-%{release}
42
43 %description -n mysqldiff
44 mysqldiff is a Perl script front-end to the CPAN module MySQL::Diff
45 which compares the data structures (i.e. table definitions) of two
46 MySQL databases, and returns the differences as a sequence of MySQL
47 commands suitable for piping into mysql which will transform the
48 structure of the first database to be identical to that of the second
49 (c.f. diff and patch). Database structures can be compared whether
50 they are files containing table definitions or existing databases,
51 local or remote.
52
53 %description -n mysqldiff -l pl.UTF-8
54 mysqldiff to skrypt Perla będący frontendem do modułu CPAN MySQL::Diff
55 porównującego struktury danych (np. definicje tabel) dwóch baz danych
56 MySQL i zwracający różnice jako sekwencje poleceń MySQL odpowiednie do
57 przekierowania do polecenia mysql, które przekształci strukturę
58 pierwszej bazy danych tak, aby była identyczna z drugą (podobnie jak
59 diff i patch). Struktury bazy danych mogą być porównywane jeśli są
60 plikami zawierającymi definicje tabel albo istniejącymi bazami -
61 lokalnymi lub zdalnymi.
62
63 %prep
64 %setup -q -n %{pdir}-%{pnam}-%{version}
65
66 %build
67 %{__perl} Makefile.PL \
68         INSTALLDIRS=vendor
69
70 %{__make}
71
72 %{?with_tests:%{__make} test}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc README
86 %dir %{perl_vendorlib}/MySQL
87 %{perl_vendorlib}/MySQL/Diff.pm
88 %dir %{perl_vendorlib}/MySQL/Diff
89 %{perl_vendorlib}/MySQL/Diff/Database.pm
90 %{perl_vendorlib}/MySQL/Diff/Table.pm
91 %{perl_vendorlib}/MySQL/Diff/Utils.pm
92 %{_mandir}/man3/MySQL::Diff.3pm*
93 %{_mandir}/man3/MySQL::Diff::Database.3pm*
94 %{_mandir}/man3/MySQL::Diff::Table.3pm*
95 %{_mandir}/man3/MySQL::Diff::Utils.3pm*
96
97 %files -n mysqldiff
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_bindir}/mysqldiff
100 %{_mandir}/man1/mysqldiff.1p*
This page took 0.108547 seconds and 4 git commands to generate.