]> git.pld-linux.org Git - packages/perl-MouseX-ConfigFromFile.git/blob - perl-MouseX-ConfigFromFile.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-MouseX-ConfigFromFile.git] / perl-MouseX-ConfigFromFile.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    MouseX
6 %define pnam    ConfigFromFile
7 Summary:        MouseX::ConfigFromFile - An abstract Mouse role for setting attributes from a configfile
8 Summary(pl.UTF-8):      MouseX::ConfigFromFile - abstrakcyjna rola Mouse do ustawiania atrybutów z pliku konfiguracyjnego
9 Name:           perl-MouseX-ConfigFromFile
10 Version:        0.05
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://search.cpan.org/CPAN/authors/id/M/MA/MASAKI/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  f6dc7f738085611949510c07301402ca
16 URL:            http://search.cpan.org/dist/MouseX-ConfigFromFile/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(MouseX::Types::Path::Class) >= 0.05
21 BuildRequires:  perl-Mouse
22 BuildRequires:  perl(Any::Moose) >= 0.05
23 BuildRequires:  perl(Test::UseAllModules)
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This is an abstract role which provides an alternate constructor for
30 creating objects using parameters passed in from a configuration file.
31 The actual implementation of reading the configuration file is left to
32 concrete subroles.
33
34 It declares an attribute configfile and a class method
35 new_with_config, and requires that concrete roles derived from it
36 implement the class method get_config_from_file.
37
38 Attributes specified directly as arguments to new_with_config
39 supercede those in the configfile.
40
41 %description -l pl.UTF-8
42 MouseX::ConfigFromFile - abstrakcyjna rola Mouse do ustawiania atrybutów z pliku konfiguracyjnego
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorlib}/MouseX/*.pm
67 %{_mandir}/man3/*
This page took 0.079105 seconds and 4 git commands to generate.