]> git.pld-linux.org Git - packages/perl-MooseX-Types.git/blob - perl-MooseX-Types.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-MooseX-Types.git] / perl-MooseX-Types.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    MooseX
6 %define pnam    Types
7 Summary:        MooseX::Types - Organise your Moose types in libraries
8 Summary(pl.UTF-8):      MooseX::Types - porządkuje typy Moose w biblioteki
9 Name:           perl-MooseX-Types
10 Version:        0.31
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/MooseX/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  aea9a4cc6760e73ebb41604006e65ca1
17 URL:            http://search.cpan.org/dist/MooseX-Types/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Carp-Clan >= 6.00
22 BuildRequires:  perl-Moose >= 1.06
23 BuildRequires:  perl-Sub-Install >= 0.924
24 BuildRequires:  perl-Sub-Name
25 BuildRequires:  perl-Test-Fatal
26 BuildRequires:  perl-Test-Requires
27 BuildRequires:  perl-namespace-clean >= 0.19
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The types provided with Moose are by design global. This package helps
34 you to organise and selectively import your own and the built-in types
35 in libraries. As a nice side effect, it catches typos at compile-time
36 too.
37
38 However, the main reason for this module is to provide an easy way to
39 not have conflicts with your type names, since the internal fully
40 qualified names of the types will be prefixed with the library's name.
41
42 This module will also provide you with some helper functions to make
43 it easier to use Moose types in your code.
44
45 String type names will produce a warning, unless it's for a class_type
46 or role_type declared within the library, or a fully qualified name
47 like 'MyTypeLibrary::Foo'.
48
49
50
51 %description -l pl.UTF-8
52 Typy Moose dostarczona są zgodne z projektem globalnym. Pakiet ten
53 pomaga zorganizować i selektywnie importować własne oraz wbudowane
54 typy z bibliotek. Jako miły skutek uboczny, wychwytuje również
55 literówki w czasie kompilacji.
56
57 Jednakże głównym celem tego modułu jest dostarczenie łatwego sposobu,
58 aby uniknąć konfliktów ze swoimi nazwami typów, ponieważ wbudowane
59 nazwy typów będzą opatrzone prefiksem z nazwą biblioteki.
60
61 Moduł ten będzie również dostarczać niektóre funkcje pomocnicze, aby
62 ułatwić użycie typów Moose w kodzie.
63
64 Napis typu nazwy dadzą ostrzeżenie, chyba że jest to dla class_type
65 lub role_type zadeklarowanych w bibliotece lub w wbudowana nazwa jak
66 'MyTypeLibrary::Foo'.
67
68 %prep
69 %setup -q -n %{pdir}-%{pnam}-%{version}
70
71 %build
72 %{__perl} Makefile.PL \
73         INSTALLDIRS=vendor
74 %{__make}
75
76 %{?with_tests:%{__make} test}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} pure_install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc Changes README
90 %{perl_vendorlib}/MooseX/*.pm
91 %{perl_vendorlib}/MooseX/Types
92 %{_mandir}/man3/*
This page took 0.092196 seconds and 4 git commands to generate.