]> git.pld-linux.org Git - packages/perl-Moose-Autobox.git/blob - perl-Moose-Autobox.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Moose-Autobox.git] / perl-Moose-Autobox.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Moose
6 %define pnam    Autobox
7 Summary:        Moose::Autobox - Autoboxed wrappers for Native Perl datatypes
8 Summary(pl.UTF-8):      Moose:Autobox = Autoboxowane opakowania dla natywnych typów danych perla
9 Name:           perl-Moose-Autobox
10 Version:        0.11
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Moose-Autobox-%{version}.tar.gz
16 # Source0-md5:  9d2e237c2cbe7e2cfe3afe8f0bbf75e7
17 URL:            http://search.cpan.org/dist/Moose-Autobox/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(autobox) >= 2.23
22 BuildRequires:  perl(Perl6::Junction) >= 1.40000
23 BuildRequires:  perl-Moose >= 0.42
24 BuildRequires:  perl-Test-Exception >= 0.21
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Moose::Autobox provides an implementation of SCALAR, ARRAY, HASH &
31 CODE for use with autobox. It does this using a hierarchy of roles in
32 a manner similar to what Perl 6 might do. This module, like Class::MOP
33 and Moose, was inspired by my work on the Perl 6 Object Space, and the
34 'core types' implemented there.
35
36 The autobox module provides the ability for calling 'methods' on
37 normal Perl values like Scalars, Arrays, Hashes and Code references.
38 This gives the illusion that Perl's types are first-class objects.
39 However, this is only an illusion, albeit a very nice one. I created
40 this module because autobox itself does not actually provide an
41 implementation for the Perl types but instead only provides the
42 'hooks' for others to add implementation too.
43
44 Several people are using this module in serious applications and it
45 seems to be quite stable. The underlying technologies of autobox and
46 Moose::Role are also considered stable. There is some performance hit,
47 but as I am fond of saying, nothing in life is free. If you have any
48 questions regarding this module, either email me, or stop by #moose on
49 irc.perl.org and ask around.
50
51 # %description -l pl.UTF-8
52 # TODO
53
54 %prep
55 %setup -q -n %{pdir}-%{pnam}-%{version}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} pure_install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes README
79 %dir %{perl_vendorlib}/Moose
80 %{perl_vendorlib}/Moose/*.pm
81 %{perl_vendorlib}/Moose/Autobox
82 %{_mandir}/man3/*
83 %{_examplesdir}/%{name}-%{version}
This page took 0.110201 seconds and 4 git commands to generate.