]> git.pld-linux.org Git - packages/perl-MooX-HandlesVia.git/blob - perl-MooX-HandlesVia.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-MooX-HandlesVia.git] / perl-MooX-HandlesVia.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    MooX
6 %define         pnam    HandlesVia
7 Summary:        MooX::HandlesVia - NativeTrait-like behavior for Moo
8 Name:           perl-MooX-HandlesVia
9 Version:        0.001007
10 Release:        2
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/MooX/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  9744cfe9e431c6510d73409a27522e47
16 URL:            http://search.cpan.org/dist/MooX-HandlesVia/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(Data::Perl) >= 0.002006
21 BuildRequires:  perl(MooX::Types::MooseLike::Base) >= 0.23
22 BuildRequires:  perl-Class-Method-Modifiers
23 BuildRequires:  perl-Module-Runtime
24 BuildRequires:  perl-Moo >= 1.003000
25 BuildRequires:  perl-Role-Tiny
26 BuildRequires:  perl-Test-Exception
27 BuildRequires:  perl-Test-Fatal
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 MooX::HandlesVia is an extension of Moo's 'handles' attribute
34 functionality. It provides a means of proxying functionality from an
35 external class to the given atttribute. This is most commonly used as
36 a way to emulate 'Native Trait' behavior that has become commonplace
37 in Moose code, for which there was no Moo alternative.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes TODO
61 %{perl_vendorlib}/MooX/HandlesVia.pm
62 %dir %{perl_vendorlib}/Data/Perl/Bool
63 %{perl_vendorlib}/Data/Perl/Bool/MooseLike.pm
64 %dir %{perl_vendorlib}/Data/Perl/Collection
65 %dir %{perl_vendorlib}/Data/Perl/Collection/Array
66 %{perl_vendorlib}/Data/Perl/Collection/Array/MooseLike.pm
67 %dir %{perl_vendorlib}/Data/Perl/Collection/Hash
68 %{perl_vendorlib}/Data/Perl/Collection/Hash/MooseLike.pm
69 %dir %{perl_vendorlib}/Data/Perl/Number
70 %{perl_vendorlib}/Data/Perl/Number/MooseLike.pm
71 %dir %{perl_vendorlib}/Data/Perl/String
72 %{perl_vendorlib}/Data/Perl/String/MooseLike.pm
73 %{_mandir}/man3/*
This page took 0.072499 seconds and 4 git commands to generate.