]> git.pld-linux.org Git - packages/perl-Module-Util.git/blob - perl-Module-Util.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Module-Util.git] / perl-Module-Util.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Module
6 %define         pnam    Util
7 Summary:        Module::Util - Module name tools and transformations
8 Name:           perl-Module-Util
9 Version:        1.09
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  4b7cc19f3f998e2d543ae033fbcb5666
16 URL:            http://search.cpan.org/dist/Module-Util/
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module provides a few useful functions for manipulating module
25 names. Its main aim is to centralise some of the functions commonly
26 used by modules that manipulate other modules in some way, like
27 converting module names to relative paths.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Build.PL \
34         destdir=$RPM_BUILD_ROOT \
35         installdirs=vendor
36 ./Build
37
38 %{?with_tests:./Build test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 ./Build install
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc Changes README
51 %{perl_vendorlib}/Module/*.pm
52 %attr(755,root,root) %{_bindir}/pm_which
53 %{_mandir}/man1/pm_which.1p*
54 %{_mandir}/man3/*
This page took 0.068424 seconds and 4 git commands to generate.