]> git.pld-linux.org Git - packages/perl-Module-Runtime.git/blob - perl-Module-Runtime.spec
- macros for perl autodeps
[packages/perl-Module-Runtime.git] / perl-Module-Runtime.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Module
6 %define         pnam    Runtime
7 Summary:        Module::Runtime - runtime module handling
8 Summary(pl.UTF-8):      Module::Runtime - obsługa modułów w czasie działania
9 Name:           perl-Module-Runtime
10 Version:        0.016
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d3d47222fa2e3dfcb4526f6cc8437b20
17 URL:            https://metacpan.org/release/Module-Runtime
18 BuildRequires:  perl-Module-Build
19 %{?with_tests:BuildRequires:    perl-Test-Simple >= 0.41}
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The functions exported by this module deal with runtime handling of
28 Perl modules, which are normally handled at compile time.
29
30 %description -l pl.UTF-8
31 Ten moduł eksportuje funkcje pozwalające obsłużyć w czasie działania
32 programu moduły Perla, które są zwykle obsługiwane w czasie
33 kompilacji.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Build.PL \
40         destdir=$RPM_BUILD_ROOT \
41         installdirs=vendor
42 ./Build
43
44 %{?with_tests:./Build test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 ./Build install
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/Module/Runtime.pm
58 %{_mandir}/man3/Module::Runtime.3pm*
This page took 0.082166 seconds and 3 git commands to generate.