]> git.pld-linux.org Git - packages/perl-Module-Pluggable-Ordered.git/blob - perl-Module-Pluggable-Ordered.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Module-Pluggable-Ordered.git] / perl-Module-Pluggable-Ordered.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Module
6 %define pnam    Pluggable-Ordered
7 Summary:        Module::Pluggable::Ordered - call module plugins in a specified order
8 Summary(pl.UTF-8):      Module::Pluggable::Ordered - wywoływanie modułów-wtyczek w zadanej kolejności
9 Name:           perl-Module-Pluggable-Ordered
10 Version:        1.5
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a9a33859fa3ff61a845035d44a2f73e8
17 URL:            http://search.cpan.org/dist/Module-Pluggable-Ordered/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Module-Pluggable >= 1.9
22 BuildRequires:  perl-UNIVERSAL-require
23 %endif
24 Requires:       perl-dirs >= 1.0-5
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module behaves exactly the same as Module::Pluggable, supporting
30 all of its options, but also mixes in the call_plugins method to your
31 class. call_plugins acts a little like Class::Trigger; it takes the
32 name of a method, and some parameters. Let's say we call it like so:
33
34 __PACKAGE__->call_plugins("my_method", @something);
35
36 call_plugins looks at the plugin modules found using Module::Pluggable
37 for ones which provide my_method_order. It sorts the modules
38 numerically based on the result of this method, and then calls
39 $my_method(@something) on them in order. This produces an effect a
40 little like the System V init process, where files can specify where
41 in the init sequence they want to be called.
42
43 %description -l pl.UTF-8
44 Ten moduł zachowuje się dokładnie tak samo jak Module::Pluggable,
45 obsługując wszystkie jego opcje, ale dodatkowo włącza do klasy metodę
46 call_plugins. call_plugins zachowuje się jak Class::Trigger; przyjmuje
47 nazwę metody i parametry. W przypadku wywołania powiedzmy:
48
49 __PACKAGE__->call_plugins("my_method", @something);
50
51 call_plugins przeszukuje moduły wtyczek znalezione przy użyciu
52 Module::Pluggable pod kątem tych, które dostarczają my_method_order.
53 Sortuje moduły liczbowo w oparciu o wynik tej metody i wywołuje po
54 kolei na nich $my_method(@something). Daje to efekt podobny trochę do
55 procesu inicjalizacji Systemu V, gdzie pliki mogą określić sekwencję
56 startową, w jakiej mają być wywoływane.
57
58 %prep
59 %setup -q -n %{pdir}-%{pnam}-%{version}
60
61 %build
62 %{__perl} Makefile.PL \
63         INSTALLDIRS=vendor
64 %{__make}
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes
80 %{perl_vendorlib}/Module/Pluggable/*.pm
81 %{_mandir}/man3/*
This page took 0.091616 seconds and 4 git commands to generate.