]> git.pld-linux.org Git - packages/perl-Module-Find.git/blob - perl-Module-Find.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Module-Find.git] / perl-Module-Find.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Module
6 %define pnam    Find
7 Summary:        Module::Find - Find and use installed modules in a (sub)category
8 Summary(pl.UTF-8):      Module::Find - wyszukiwanie i używanie modułów w (pod)kategorii
9 Name:           perl-Module-Find
10 Version:        0.13
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  28a11699901c2b07795ad59827d6ee66
17 URL:            http://search.cpan.org/dist/Module-Find/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Pod >= 1.14
22 BuildRequires:  perl-Test-Pod-Coverage >= 1.04
23 BuildRequires:  perl-Test-Simple
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Module::Find lets you find and use modules in categories. This can be
30 very useful for auto-detecting driver or plugin modules. You can
31 differentiate between looking in the category itself or in all
32 subcategories.
33
34 %description -l pl.UTF-8
35 Module::Find pozwala odnaleźć i używać moduly w kategoriach. Może to
36 być bardzo przydatne do automatycznego wykrywania modułów sterowników
37 lub wtyczek. Można rozróżnić pomiędzy szukaniem w ramach samej
38 kategorii lub we wszystkich podkategoriach.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/Module/Find.pm
63 %{_mandir}/man3/Module::Find.3pm*
This page took 0.079249 seconds and 4 git commands to generate.