]> git.pld-linux.org Git - packages/perl-Module-CPANfile.git/blob - perl-Module-CPANfile.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Module-CPANfile.git] / perl-Module-CPANfile.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 Summary:        Parse cpanfile
6 Name:           perl-Module-CPANfile
7 Version:        1.0001
8 Release:        1
9 License:        GPL+ or Artistic
10 Group:          Development/Libraries
11 Source0:        http://www.cpan.org/authors/id/M/MI/MIYAGAWA/Module-CPANfile-%{version}.tar.gz
12 # Source0-md5:  d1fa25121f0409182a21b2ef89ab58e0
13 URL:            http://search.cpan.org/dist/Module-CPANfile/
14 BuildRequires:  perl(CPAN::Meta) >= 2.12091
15 BuildRequires:  perl(CPAN::Meta::Feature) >= 2.12091
16 BuildRequires:  perl(CPAN::Meta::Prereqs) >= 2.12091
17 BuildRequires:  perl(Carp)
18 BuildRequires:  perl(Cwd)
19 BuildRequires:  perl(Data::Dumper)
20 BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.30
21 BuildRequires:  perl(base)
22 BuildRequires:  perl(strict)
23 BuildRequires:  perl(warnings)
24 BuildRequires:  perl-Encode
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 %if %{with tests}
27 BuildRequires:  perl(Exporter)
28 BuildRequires:  perl(POSIX)
29 BuildRequires:  perl(Test::More) >= 0.88
30 %endif
31 Requires:       perl(CPAN::Meta) >= 2.12091
32 Requires:       perl(CPAN::Meta::Feature) >= 2.12091
33 Requires:       perl(CPAN::Meta::Prereqs) >= 2.12091
34 Requires:       perl(Data::Dumper)
35 Requires:       perl(Pod::Usage)
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Module::CPANfile is a tool to handle cpanfile format to load
41 application specific dependencies, not just for CPAN distributions.
42
43 %prep
44 %setup -q -n Module-CPANfile-%{version}
45
46 %build
47 %{__perl} Makefile.PL INSTALLDIRS=vendor
48 %{__make}
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %{__make} pure_install \
54         PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
55
56 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Module/CPANfile/.packlist
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes LICENSE README
64 %attr(755,root,root) %{_bindir}/mymeta-cpanfile
65 %{_mandir}/man1/mymeta-cpanfile*
66 %{_mandir}/man3/Module::CPANfile.3pm*
67 %{_mandir}/man3/cpanfile-faq.3pm*
68 %{_mandir}/man3/cpanfile.3pm*
69 %{perl_vendorlib}/Module/CPANfile.pm
70 %{perl_vendorlib}/Module/CPANfile
71 %{perl_vendorlib}/cpanfile-faq.pod
72 %{perl_vendorlib}/cpanfile.pod
This page took 0.082851 seconds and 4 git commands to generate.