]> git.pld-linux.org Git - packages/perl-Module-Build-WithXSpp.git/blob - perl-Module-Build-WithXSpp.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Module-Build-WithXSpp.git] / perl-Module-Build-WithXSpp.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Module
6 %define         pnam    Build-WithXSpp
7 Summary:        Module::Build::WithXSpp - XS++ enhanced flavour of Module::Build
8 Name:           perl-Module-Build-WithXSpp
9 Version:        0.14
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  f3d6ad08127f62eed9baef131870f450
16 URL:            http://search.cpan.org/dist/Module-Build-WithXSpp/
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(ExtUtils::CppGuess) >= 0.04
22 BuildRequires:  perl(ExtUtils::XSpp) >= 0.11
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This subclass of Module::Build adds some tools and
29 processes to make it easier to use for wrapping C++
30 using XS++ (ExtUtils::XSpp).
31
32 There are a few minor differences from using Module::Build
33 for an ordinary XS module and a few conventions that you
34 should be aware of as an XS++ module author. They are documented
35 in the /"FEATURES AND CONVENTIONS" section below. But if you
36 can't be bothered to read all that, you may choose skip it and
37 blindly follow the advice in /"JUMP START FOR THE IMPATIENT".
38
39 An example of a full distribution based on this build tool
40 can be found in the ExtUtils::XSpp distribution under
41 examples/XSpp-Example. Using that example as the basis
42 for your Module::Build::WithXSpp-based distribution
43 is probably a good idea.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Build.PL \
50         destdir=$RPM_BUILD_ROOT \
51         installdirs=vendor
52 ./Build
53
54 %{?with_tests:./Build test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 ./Build install
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorlib}/Module/Build/*.pm
68 #%{perl_vendorlib}/Module/Build/WithXSpp
69 %{_mandir}/man3/*
This page took 0.070326 seconds and 4 git commands to generate.